Honda Accord & Crosstour (2003 - 2012) 2003 - 2012 Honda Accord and Inspire

oem vs aftermarket problem

 
Old 10-27-2018, 04:47 AM
  #1  
Honda-Tech Member
Thread Starter
 
Join Date: Oct 2018
Posts: 6
Default oem vs aftermarket problem

09 accord 2.4 2dr auto. have vsa and ce light code says maf sensor changed that, came back on couple days later code now says crank pos. sensor, changed that with aftermarket. code now says vtc sensor. starter also went bad. I changed starter before changing crank sensor. lights came back on. went to honda dealer says ecu needs updating had that done car stuck on side of road with blinking ce light withing 5 miles of dealer. dealer claims its the starter not being oem put original crank sensor says still starter not spinning engine over correctly as oem would and giving wrong reading to ecu. is this true or story?
jim-g is offline  
Old 10-27-2018, 06:25 AM
  #2  
Honda-Tech Member
 
Chrisfrom1986's Avatar
 
Join Date: Jan 2006
Location: Fresno, CA
Posts: 442
Default Re: oem vs aftermarket problem

Bullshit. Also stop wasting money just buying parts and get it diagnosed at a different dealer or speak with a manager about the stupidity of whoever told you an aftermarket starter won't work, they're obviously trying to bait an ignorant customer into buying unnecessary parts.
Chrisfrom1986 is offline  
Old 10-27-2018, 07:12 AM
  #3  
Honda-Tech Member
Thread Starter
 
Join Date: Oct 2018
Posts: 6
Default Re: oem vs aftermarket problem

Originally Posted by Chrisfrom1986 View Post
Bullshit. Also stop wasting money just buying parts and get it diagnosed at a different dealer or speak with a manager about the stupidity of whoever told you an aftermarket starter won't work, they're obviously trying to bait an ignorant customer into buying unnecessary parts.
figured so. i changed the maf. and cps after that knew Ii was just being parts changer but even after update edu vsa and misfire still happening. i plan on going elsewhere . i did get into it with service manager and 2 techs, both say I'm wrong starter is causing voltage problems
thanks for the reply
jim-g is offline  
Old 10-30-2018, 10:31 AM
  #4  
Honda-Tech Member
 
DCFIVER's Avatar
 
Join Date: Mar 2004
Location: failing a car near you.....
Posts: 4,307
Default Re: oem vs aftermarket problem

Originally Posted by Chrisfrom1986 View Post
Bullshit. Also stop wasting money just buying parts and get it diagnosed at a different dealer or speak with a manager about the stupidity of whoever told you an aftermarket starter won't work, they're obviously trying to bait an ignorant customer into buying unnecessary parts.
DCFIVER is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: