Go Back  Honda-Tech - Honda Forum Discussion > Honda and Acura Technical Forums > Forced Induction
Reload this Page >

Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Troubleshooting: B18CR Turbo running too much fuel - running idle issue

 
Old 10-22-2018, 09:21 AM
  #1  
Ad9
Trial User
Thread Starter
 
Join Date: Oct 2018
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Hello, I just finished installing a turbo setup for my B18CR and when I wen't to start it up the car would idle very rough and would die within a few seconds if I didn't give it lots of gas (would sometimes die even when giving gas). I then checked datalogs through hondata and saw AFRs hovering around 1:1 - 3:1 vs the normal 12:1. I tried starting the car a few times and every time it was the same deal. I had upgraded the injectors to 550cc from 240cc (also did the tuning in the fuel injectors params section for hondata) so I thought it must be the new injectors maybe dumping too much fuel, so i switched to the old ones but it was the same story! So then I thought it might actually be an issue with the air, so I removed the intercooler piping that connects to the intake manifold and started the car up naturally aspirated running unfiltered air and it was running again and even idling ok. At this point I'm thinking the engine is not receiving enough air for some reason. I checked the turbo and it does seem to be spinning fine and blows air through the intercooler piping but maybe not enough? Anyone got an ideas of what I should check or what the issue could be?
Ad9 is offline  
Old 10-22-2018, 01:16 PM
  #2  
Honda-Tech Member
 
93h2beg's Avatar
 
Join Date: Jul 2010
Location: Northern California
Posts: 458
Likes: 0
Received 0 Likes on 0 Posts
Default re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

My guess- Cam timing is off.
93h2beg is offline  
Old 10-22-2018, 01:36 PM
  #3  
Ad9
Trial User
Thread Starter
 
Join Date: Oct 2018
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Could a leak in the intercooler piping cause such a huge difference in how the car runs when not under boost? The car runs insanely rich and dies after a few seconds vs runs fine when the intercooler piping is connected vs not connected.
Ad9 is offline  
Old 10-22-2018, 01:59 PM
  #4  
Honda-Tech Member
 
turboLScrx's Avatar
 
Join Date: Mar 2001
Location: Bowling Green, ky, USA
Posts: 764
Likes: 0
Received 0 Likes on 0 Posts
Default re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Originally Posted by Ad9 View Post
Could a leak in the intercooler piping cause such a huge difference in how the car runs when not under boost? The car runs insanely rich and dies after a few seconds vs runs fine when the intercooler piping is connected vs not connected.
i doubt that would be the case, it almost sounds like the program never made the adjustments for the new injectors, you did upload or save the new settings? Might try swapping back to the old injectors also
turboLScrx is offline  
Old 10-22-2018, 07:36 PM
  #5  
Honda-Tech Member
 
Chance EG's Avatar
 
Join Date: Jan 2013
Location: Austin, TX
Posts: 1,651
Likes: 0
Received 0 Likes on 0 Posts
Default re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Seriously? 1:1 or 3:1 AFR? Jesus christ.

What AFR were you seeing with the intercooler pipe disconnected? Have you checked your pipes and intercooler for blockages? Have you set injector dead times, and made CERTAIN you have them properly entered in the tune? Have you confirmed mechanical timing?
Chance EG is offline  
Old 10-23-2018, 10:23 AM
  #6  
Ad9
Trial User
Thread Starter
 
Join Date: Oct 2018
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Okay I compared the 550cc injectors with the stock 240cc and the 550cc run like complete garbage... seriously 1:1 AFR with 55 degree timing advance at 2k rpms lol. I set the correct dead times and even adjusted some fuel tables but it didn't help anything. I won't lie I didn't have obd1 injector connecting clips so I modified the obd2 ones to make them fit the 550cc injectors. Could be a connection issue or that the injectors are just garbage to begin with. Also the car smokes like a chimney but that could be my poorly routed oil return line. I removed the oil feed from the top of the turbo and saw that the turbo was completely filled with oil. My fitting on the oil pan comes out at a downwards angle so I'm not too sure how to fix it other than drilling a new hole in the oil pan or maybe using an oil scavenging pump.
Ad9 is offline  
Old 10-23-2018, 10:32 AM
  #7  
Moderator
iTrader: (12)
 
TheShodan's Avatar
 
Join Date: Jan 2002
Location: City of Wind, IL, USA
Posts: 23,361
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

did you use a resistor pack? what 550cc injectors are they? Rochester Lucas? Delphi? Bosch. That makes a BIG difference. You're probably not getting the right ohm resistance for the computer to be able to adjust dead times.
TheShodan is offline  
Old 10-23-2018, 11:15 AM
  #8  
Ad9
Trial User
Thread Starter
 
Join Date: Oct 2018
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Injectors were $175 off ebay, most likely white label chinese injectors. They are high resistance ~ 12ohms. Don't think I need a resistor pack with these, especially when the manufacturer said to remove the oem resistor box in pre 1991 hondas. However, I am regretting not getting a good pair of injector dynamics right now.
Ad9 is offline  
Old 10-23-2018, 01:20 PM
  #9  
Moderator
iTrader: (12)
 
TheShodan's Avatar
 
Join Date: Jan 2002
Location: City of Wind, IL, USA
Posts: 23,361
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Troubleshooting: B18CR Turbo running too much fuel - running idle issue

Originally Posted by Ad9 View Post
Injectors were $175 off ebay, most likely white label chinese injectors. They are high resistance ~ 12ohms. Don't think I need a resistor pack with these, especially when the manufacturer said to remove the oem resistor box in pre 1991 hondas. However, I am regretting not getting a good pair of injector dynamics right now.
High impedance... Did you confirm with a multimeter?
There are out injectors other than injector dynamics. If you need less expensive, get some Rochester/Lucas or Precision low impedance injectors with a pack.. Or get some other Bosch Injectors
TheShodan is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: