TPS and MAP codes need help - Honda-Tech - Honda Forum Discussion

Honda Civic / Del Sol (1992 - 2000) EG/EH/EJ/EK/EM1 Discussion

TPS and MAP codes need help

 
Old 03-14-2019, 08:29 AM
  #1  
Trial User
Thread Starter
 
Join Date: Mar 2019
Posts: 2
Default TPS and MAP codes need help

Hello all, new to the forum although I've been browsing for awhile. Long story so bear with me.

Recently purchased a 93 civic coupe DX (1.6 vtec swapped) from my brother to use as a daily beater to get miles off my current car. He owned the car for 12 years with relatively few issues. The car has been sitting about a year when i decided to pick it up. I put fresh gas, changed the oil and did a few minor things to get it road ready. The car ran flawless for about 200 miles. I was driving to work and the car lost power, CEL came on, I was pushing the throttle but nothing was happening, then it died. I coasted to the side of the road and tried to restart, would run but when I gave it gas it would shut back off. After about 10 minutes it started up and ran fine the rest of the way to work. I went out at lunch and tried to start it but it would run for a split second and then die. Checked codes, had codes for MAP sensor, TPS and vtec (VTEC is not a concern, my brother says that would randomly come on and go off, thinks it is a wiring issue, and I don't drive the car hard so I do not care if VTEC works or not).

I unplugged the TPS and it would start and run, plug TPS in while running it would continue to run, only if I tried to start with TPS plugged in it would shut off. MAP sensor made no difference on running or not. I did not attempt to drive the car at this point. Few days later (TPS plugged in) I swapped the map sensor with a known good part and the cleared the codes. Car started up and ran, no CEL. Swapped back to my old MAP and same thing, run and no CEL. So ok at this point I drive the car with the old MAP sensor, TPS plugged in, basically how it was when it started having the issue. Ran fine, did a short trip and ran it hard into VTEC, VTEC worked, a few miles on while driving hard the CEL came back on. Car continued to run fine, checked the codes, all codes returned. TPS, MAP and VTEC. Using a multimeter I checked voltage on the TPS and checks out within spec. (.48 at idle, 4.4 WOT if I recall correctly)

So at this point the car seems to run ok, however with a check engine light. I'm reluctant to drive it home from work yet because I drive through a long section of 2 lane construction with no emergency pull offs. So I would hate for it to break down there. I'm kind of at a loss as to what could be causing the issue. Next step is to swap the MAP sensor again and drive the car to see if codes return. Any ideas? Thanks for any help!
shodown220 is offline  
Old 03-14-2019, 02:27 PM
  #2  
Honda-Tech Member
 
Join Date: Apr 2016
Posts: 156
Default Re: TPS and MAP codes need help

Why didn't you leave the "new" or the MAP that you knew was good on the car?
Joey Mitchell is offline  
Old 03-14-2019, 02:29 PM
  #3  
Trial User
Thread Starter
 
Join Date: Mar 2019
Posts: 2
Default Re: TPS and MAP codes need help

Originally Posted by Joey Mitchell View Post
Why didn't you leave the "new" or the MAP that you knew was good on the car?
it was borrowed off of a coworker's civic, had to give it back lol
shodown220 is offline  
Old 03-14-2019, 10:37 PM
  #4  
Honda-Tech Member
 
Join Date: Apr 2016
Posts: 156
Default Re: TPS and MAP codes need help

Originally Posted by shodown220 View Post
it was borrowed off of a coworker's civic, had to give it back lol
Oh I got you dude. Id go about testing my MAP sensor and see if it's bad at this point.
Joey Mitchell is offline  
 


Thread Tools
Search this Thread

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: