00 honda civic ls swap, fuel pump wont prime, brand new relay - Honda-Tech - Honda Forum Discussion


Honda Civic / Del Sol (1992 - 2000) EG/EH/EJ/EK/EM1 Discussion

00 honda civic ls swap, fuel pump wont prime, brand new relay

Reply
 
 
 
Thread Tools Search this Thread
Old 08-07-2017, 08:15 PM   #1
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default 00 honda civic ls swap, fuel pump wont prime, brand new relay

Hi, i did a ls swap in my 2000 honda civic, got everything hooked up fine ready to crank and the first time i tried starting it I didnt hear the fuel pump prime. Therefore i put a multimeter on the main relay connections and all made 12v EXCEPT #7. (fuel pump) This is also with a brand new relay. I already wired a live wire from battery to #7 and it primed so i know the pump is good. Any ideas that might be able to help?
When i turn the ignition switch off, i can hear the relay click.

Last edited by Nitrozity74; 08-09-2017 at 07:05 PM.
Nitrozity74 is offline   Reply With Quote
Old 08-08-2017, 06:05 AM   #2
Honda-Tech Member
 
Join Date: Feb 2016
Posts: 1,529
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Check the ECU grounds. When you turn key on and don't crank, does the check engine light come on then go out?
mk378 is online now   Reply With Quote
Old 08-08-2017, 08:14 AM   #3
Honda-Tech Member
 
tony_2018's Avatar
 
Join Date: Nov 2005
Location: Central Valley, CA
Posts: 9,806
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

google 'swaps into 2000 obd2b civics'
look up verify your ecu wiring is correct
tony_2018 is online now   Reply With Quote
Old 08-08-2017, 06:10 PM   #4
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

No lights come on the dash except my battery light. Battery is charged and getting 12 volts. I am going to double check my grounds again tonight but im almost positive all grounds were good.
Nitrozity74 is offline   Reply With Quote
Old 08-09-2017, 07:04 PM   #5
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Bump, still no luck.
Nitrozity74 is offline   Reply With Quote
Old 08-09-2017, 08:48 PM   #6
Honda-Tech Member
 
dgdarien's Avatar
 
Join Date: Mar 2002
Posts: 473
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

My fuel pump wouldn't prime recently either; the ECU was dead.
dgdarien is offline   Reply With Quote
Old 08-10-2017, 05:26 AM   #7
Honda-Tech Member
 
Join Date: Feb 2016
Posts: 1,529
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Turning the key on but not starting, the oil pressure light should also come on. That light is on the same circuit that supplies the ECU and the ignition.
mk378 is online now   Reply With Quote
Old 08-10-2017, 06:25 PM   #8
Technical Hero
 
HondaPartsHero's Avatar
 
Join Date: May 2002
Location: Charlotte, NC, 28227
Posts: 9,846
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

What ECU and how did you wire everything
HondaPartsHero is offline   Reply With Quote
Old 08-10-2017, 08:34 PM   #9
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Usong a chipped p28 ecu. Like i said absolutely no lights on the dash other than brake and battery
Nitrozity74 is offline   Reply With Quote
Old 08-11-2017, 03:03 PM   #10
Honda-Tech Member
 
tony_2018's Avatar
 
Join Date: Nov 2005
Location: Central Valley, CA
Posts: 9,806
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Quote:
Originally Posted by HondaPartsHero View Post
What ECU and how did you wire everything
tony_2018 is online now   Reply With Quote
Old 08-12-2017, 06:05 PM   #11
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Wire everything for what? The ecu is hooked up by a jumper harness
Nitrozity74 is offline   Reply With Quote
Old 08-12-2017, 06:36 PM   #12
Seagull Management
 
94EG8's Avatar
 
Join Date: Jun 2008
Location: Miramichi, NB, Canada
Posts: 15,019
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

You may have to move pin A16 to A15 on the engine harness.
94EG8 is offline   Reply With Quote
Old 08-17-2017, 08:36 PM   #13
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Update- Found out my ground to thermostat was bad, fixed that and it gets good ground now. the only difference is i can crank my motor now but the fuel pump still wont prime! No CEL, only lights on dash are brake and battery. Main relay is brand new, fuel pump is good. Still no solution can somebody please help
Nitrozity74 is offline   Reply With Quote
Old 08-18-2017, 08:02 AM   #14
Honda-Tech Member
 
tony_2018's Avatar
 
Join Date: Nov 2005
Location: Central Valley, CA
Posts: 9,806
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Quote:
Originally Posted by Nitrozity74 View Post
Update- Found out my ground to thermostat was bad, fixed that and it gets good ground now. the only difference is i can crank my motor now but the fuel pump still wont prime! No CEL, only lights on dash are brake and battery. Main relay is brand new, fuel pump is good. Still no solution can somebody please help
Quote:
Originally Posted by mk378 View Post
Check the ECU grounds. When you turn key on and don't crank, does the check engine light come on then go out?
dude if you can't read what has been stated just take it to a shop.
tony_2018 is online now   Reply With Quote
Old 08-19-2017, 09:04 PM   #15
Seagull Management
 
94EG8's Avatar
 
Join Date: Jun 2008
Location: Miramichi, NB, Canada
Posts: 15,019
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

The thermostat ground is the ECU ground.
94EG8 is offline   Reply With Quote
Old 08-21-2017, 12:18 PM   #16
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Heres a picture of my ecu hooked to jumper harness. Car cranks fine fuel pump wont prime still.
Nitrozity74 is offline   Reply With Quote
Old 08-21-2017, 12:21 PM   #17
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

I also found this after taking my cover off, seems like the previous owner really messed with something here. Does anybody know exactly what this plug is for?
Nitrozity74 is offline   Reply With Quote
Old 08-21-2017, 12:54 PM   #18
Honda-Tech Member
 
Join Date: Feb 2016
Posts: 1,529
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Quote:
Originally Posted by Nitrozity74 View Post
Hi, i did a ls swap in my 2000 honda civic...
Does this mean that the car was running OK with the stock D series motor and OBDIIb ECU when you first got it?
mk378 is online now   Reply With Quote
Old 08-21-2017, 08:10 PM   #19
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Quote:
Originally Posted by mk378 View Post
Does this mean that the car was running OK with the stock D series motor and OBDIIb ECU when you first got it?
The car is a 2000 si, i bought it as a shell
Nitrozity74 is offline   Reply With Quote
Old 08-22-2017, 07:50 PM   #20
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2017
Posts: 15
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

Bump.. anybody
Nitrozity74 is offline   Reply With Quote
Old 08-22-2017, 09:11 PM   #21
Honda-Tech Member
 
Join Date: Jan 2013
Location: Bama
Posts: 1,605
Default Re: 00 honda civic ls swap, fuel pump wont prime, brand new relay

I suggest you ignore the wiring at the column at this point and focus on the MESS you have over at the ECU. Your pic above shows FIVE ECU plugs... one laying in free air and another four plugged into your adapter harness meeting three on the other side. Does this not cause concern/pause for you ??? How about posting closer/clear pics of those plugs as well as the crossover plug (the green one) to see which wires do not correspond to something on the other side. My suspicion is you do not have a matching engine/dash/chassis harness group.
JRCivic1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel pump not priming; no start. dgdarien Tech / Misc 1 07-20-2017 02:37 AM
00 Civic Ex Take Long to Prime the line drzmorenito1809 Honda Civic / Del Sol (1992 - 2000) 2 11-20-2016 12:23 PM
New fuel pump and relay.. Won't prime dirtyundies Tech / Misc 21 03-26-2016 12:17 PM
eg gsr swap - Fuel pump not priming. redbull99 Honda Civic / Del Sol (1992 - 2000) 11 02-05-2016 12:31 PM
IL GEN4 MR2 LSD Turbo & Super Clean 190E forceinducted Vehicles for sale 6 12-22-2015 10:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 04:52 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: