Go Back   Honda-Tech > Honda and Acura Model-Specific Technical Forums > Honda Civic/Del Sol (1992 - 2000)
Sign in using an external account
Register Forgot Password?
Search


Welcome to Honda-Tech!
Welcome to Honda-Tech.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Honda-Tech community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
Old 05-03-2011, 06:57 AM   #1
Käras
Honda-Tech Member
Garage is empty, add now
 
Käras's Avatar
 
Join Date: Mar 2010
Location: NY
Posts: 30
iTrader Rating: (0)
Send a message via AIM to Käras
Default Injectors not firing

Ok, so upon troubleshooting some issues with my car, it seems the injectors were not spitting fuel out. So I went and got another pair, and put them in, and again, they arn't spitting. Is there a fuse/relay, that could be a problem, or would it be harness related? Its a 94 Civic EX with the d16Z6 and original Virgin P28.
__________________
94 Honda Civic EX Coupe
95 Subaru Impreza L AWD (R.I.P.)
Käras is offline   Reply With Quote
Old 05-03-2011, 07:19 AM   #2
grumblemarc
The Grumpiest
1996 Honda Civic
 
grumblemarc's Avatar
 
Join Date: May 2008
Location: Oak Ridge, TN, USA
Posts: 27,901
iTrader Rating: (4)
Send a message via AIM to grumblemarc Send a message via Yahoo to grumblemarc Send a message via Skype™ to grumblemarc
Default Re: Injectors not fireing

Only 2 injectors?
__________________
FAQs!--How to Turbocharge your Civic--Want a faster Civic?--DIYs
Quote:
Originally Posted by wantboost View Post
I wish more parents would beat their children, then maybe most of them wouldn't be total spoiled, self absorbed *********.
grumblemarc is offline   Reply With Quote
Old 05-03-2011, 07:36 AM   #3
RonJ@HT
Raising the bar
2000 Honda Civic
My Garage
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,548
iTrader Rating: (0)
Default Re: Injectors not fireing

Do the injector clips have battery voltage to body ground with the key in ON(II)?
__________________
Don't guess, troubleshoot.
Useful tech links -- FAQs; Codes; Check Spark; Test Fuses; Fuse 15 TSB; Clean IACV or FITV
RonJ@HT is offline   Reply With Quote
Old 05-08-2011, 11:29 AM   #4
Käras
Honda-Tech Member
Garage is empty, add now
 
Käras's Avatar
 
Join Date: Mar 2010
Location: NY
Posts: 30
iTrader Rating: (0)
Send a message via AIM to Käras
Default Re: Injectors not fireing

I went and bought a Noid Light, and hooked it up, It seems there is no power getting to the injectors. I've read a few different threads, all of which are making this kinda costly. The two "issues" that it may or may not be are the Main relay, or the ECU. Is there a easy way to test either to see if they are the problem? I don't have an abundance of extra parts to try this stuff around with. Any help is appreciated. Not having a car is really hurting.
__________________
94 Honda Civic EX Coupe
95 Subaru Impreza L AWD (R.I.P.)
Käras is offline   Reply With Quote
Old 05-08-2011, 05:03 PM   #5
RonJ@HT
Raising the bar
2000 Honda Civic
My Garage
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,548
iTrader Rating: (0)
Default Re: Injectors not fireing

What makes you think the injectors don't get power? What did you see?
__________________
Don't guess, troubleshoot.
Useful tech links -- FAQs; Codes; Check Spark; Test Fuses; Fuse 15 TSB; Clean IACV or FITV
RonJ@HT is offline   Reply With Quote
Old 05-08-2011, 08:41 PM   #6
fasterthanueg
Honda-Tech Member
Garage is empty, add now
 
fasterthanueg's Avatar
 
Join Date: Jul 2006
Location: vancouver, wa, usa
Posts: 481
iTrader Rating: (1)
Default Re: Injectors not firing

Check the ground plug on the driver side.
fasterthanueg is offline   Reply With Quote
Old 05-08-2011, 09:09 PM   #7
Käras
Honda-Tech Member
Garage is empty, add now
 
Käras's Avatar
 
Join Date: Mar 2010
Location: NY
Posts: 30
iTrader Rating: (0)
Send a message via AIM to Käras
Default Re: Injectors not fireing

Quote:
Originally Posted by RonJ@HT View Post
What makes you think the injectors don't get power? What did you see?
The Noid light testing thing I got, it says plug the right one into the clip (of the harness), and turn the key over as in trying to start it. If the light Flashes its getting power (pulsating), If not, then something is "wrong". Technically meaning, its not getting power.

@fasterthanueg Are you referring to the grounds in the motor bay? If so I just replaced them. The old ones were corroded and falling apart.
__________________
94 Honda Civic EX Coupe
95 Subaru Impreza L AWD (R.I.P.)
Käras is offline   Reply With Quote
Old 05-08-2011, 09:09 PM   #8
NotAJDMFanBoy
Honda-Tech Member
Garage is empty, add now
 
Join Date: Oct 2010
Posts: 1,285
iTrader Rating: (0)
Default Re: Injectors not firing

Usually the main relay manifests itself as a random no start condition, usually temperature related. The ECU is a possibility but it would be wise to check every other possibility first. If you wanted to test it and know someone with a Honda, any ECU, P28, P06, P72, P30 will run about any other motor (not recommended to drive it around, but purely for testing, it's fine).

For the grounds, take each one off and clean the mating surfaces with a wire brush or sand paper and reattach.
Make sure nobody took the weird plug out from where a resistor box would fit. And make sure all the other cannon plugs and ECU plugs are connected. Take each loose and put back in to make sure there's a connection. Corrosion is obviously a possibility on a 17 year old car.
__________________
matt93eg is a lying scammer. Avoid.
NotAJDMFanBoy is offline   Reply With Quote
Old 05-08-2011, 09:11 PM   #9
NotAJDMFanBoy
Honda-Tech Member
Garage is empty, add now
 
Join Date: Oct 2010
Posts: 1,285
iTrader Rating: (0)
Default Re: Injectors not firing

Don't our cars have constant power, but the ground is interfered with for the injectors?

And did this problem start right after replacing the ground cables? Maybe you connected it somewhere there wasn't a good connection?
__________________
matt93eg is a lying scammer. Avoid.
NotAJDMFanBoy is offline   Reply With Quote
Old 05-09-2011, 05:03 AM   #10
Käras
Honda-Tech Member
Garage is empty, add now
 
Käras's Avatar
 
Join Date: Mar 2010
Location: NY
Posts: 30
iTrader Rating: (0)
Send a message via AIM to Käras
Default Re: Injectors not firing

Quote:
Originally Posted by NotAJDMFanBoy View Post
Don't our cars have constant power, but the ground is interfered with for the injectors?

And did this problem start right after replacing the ground cables? Maybe you connected it somewhere there wasn't a good connection?
Ill defiantly do all that. I actually made the ground wires myself with 10 gauge wire, and some end connectors. I honestly can't say for sure it started at that point. I think it happened after I tried changing my cap and rotor, which to me seems like it shouldn't effect that. Ill go back and re-check the grounds, make sure they are on right, and no corrosion. Ill check all the plugs as well. As for that relay, I would have to go to the junkyard to grab one. My question for that would be, does it have to be from a D16, or would a D15 one work as well?
__________________
94 Honda Civic EX Coupe
95 Subaru Impreza L AWD (R.I.P.)
Käras is offline   Reply With Quote
Old 05-09-2011, 07:01 AM   #11
RonJ@HT
Raising the bar
2000 Honda Civic
My Garage
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,548
iTrader Rating: (0)
Default Re: Injectors not firing

You are over-interpreting what a noid tester measures. The injectors receive constant voltage via the ignition switch, and the ECU tells the injector when to fire by providing ground for this voltage. The noid tester only tells you whether the ECU is providing the pulsating ground. You need to use a multimeter or test light to check whether the injector clips get voltage.
__________________
Don't guess, troubleshoot.
Useful tech links -- FAQs; Codes; Check Spark; Test Fuses; Fuse 15 TSB; Clean IACV or FITV

Last edited by RonJ@HT; 05-09-2011 at 07:19 AM.
RonJ@HT is offline   Reply With Quote
Old 05-09-2011, 06:19 PM   #12
Käras
Honda-Tech Member
Garage is empty, add now
 
Käras's Avatar
 
Join Date: Mar 2010
Location: NY
Posts: 30
iTrader Rating: (0)
Send a message via AIM to Käras
Default Re: Injectors not firing

Quote:
Originally Posted by RonJ@HT View Post
You are over-interpreting what a noid tester measures. The injectors receive constant voltage via the ignition switch, and the ECU tells the injector when to fire by providing ground for this voltage. The noid tester only tells you whether the ECU is providing the pulsating ground. You need to use a multimeter or test light to check whether the injector clips get voltage.
Actually. all it is is a light bulb that you can connect to the harness. If the Light stays on you have that constant power, if the light blinks, it shows its pulsating. Mine however doesn't light up at all.
But if I go by what you just told me, then I might be having a problem with my ignition switch? Or would that not allow my spark plugs to fire as well (they do though).
__________________
94 Honda Civic EX Coupe
95 Subaru Impreza L AWD (R.I.P.)
Käras is offline   Reply With Quote
Old 05-09-2011, 06:35 PM   #13
old buba
Trial User
Garage is empty, add now
 
Join Date: May 2011
Posts: 1
iTrader Rating: (0)
Default Re: Injectors not firing

Eliminate your ground problem - 1st use a jumper cable from your ground directly to the battery ground. I hope you did not ground it to a plastic or fiberglass fender. Next take the air filter hose off the throttle body and have someone push down on the gas while starting the engine while you spray starting fluid past the throttle plate. This will start the engine even without fuel, it will sometimes help it get going again.
old buba is offline   Reply With Quote
Old 05-09-2011, 06:56 PM   #14
RonJ@HT
Raising the bar
2000 Honda Civic
My Garage
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,548
iTrader Rating: (0)
Default Re: Injectors not firing

Quote:
Originally Posted by Käras View Post
Actually. all it is is a light bulb that you can connect to the harness. If the Light stays on you have that constant power, if the light blinks, it shows its pulsating. Mine however doesn't light up at all.
Is this a homemade rig? Describe how you test the harness with your light.
__________________
Don't guess, troubleshoot.
Useful tech links -- FAQs; Codes; Check Spark; Test Fuses; Fuse 15 TSB; Clean IACV or FITV
RonJ@HT is offline   Reply With Quote
Old 05-09-2011, 09:21 PM   #15
fasterthanueg
Honda-Tech Member
Garage is empty, add now
 
fasterthanueg's Avatar
 
Join Date: Jul 2006
Location: vancouver, wa, usa
Posts: 481
iTrader Rating: (1)
Default Re: Injectors not firing

I was talking about this plug. If its not plugged in or messed with the pump won't turn on or objectors won't work. Click the image to open in full size. hope this helps. Good luck
fasterthanueg is offline   Reply With Quote
Old 05-10-2011, 07:15 AM   #16
Käras
Honda-Tech Member
Garage is empty, add now
 
Käras's Avatar
 
Join Date: Mar 2010
Location: NY
Posts: 30
iTrader Rating: (0)
Send a message via AIM to Käras
Default Re: Injectors not firing

Quote:
Originally Posted by RonJ@HT View Post
Is this a homemade rig? Describe how you test the harness with your light.
www.otctools.com Noid-lite Set. Its a real test set for almost any car. I work at Napa, so I buy real tools. I don't do anything cheap when it comes to my car, but I won't pay someone that I don't trust knows what they are doing. I have to go to work right now, but Ill check that plug Fasterthanueg. The pic helps a lot.

@old buba, The ground wire from the battery was originally mounted to the Throttlebody (not my doing, it was how I got it, and I have no clue how the eff I missed it). I got a regular ground wire mounted how it should be. (OEM ground from a junked civic)
__________________
94 Honda Civic EX Coupe
95 Subaru Impreza L AWD (R.I.P.)
Käras is offline   Reply With Quote
Old 05-10-2011, 07:23 AM   #17
RonJ@HT
Raising the bar
2000 Honda Civic
My Garage
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,548
iTrader Rating: (0)
Default Re: Injectors not firing

Quote:
Originally Posted by Käras View Post
www.otctools.com Noid-lite Set.
The link brings me to a site not the Noid light. Post the manufacturer's instructions for using the light.

Quote:
Its a real test set for almost any car. I work at Napa, so I buy real tools. I don't do anything cheap when it comes to my car, but I won't pay someone that I don't trust knows what they are doing.
Again, if this^ is the standard noid light that you plug into the injector clip, it will NOT tell you whether the injector plug gets voltage. If the noid light neither turns on nor pulses, then the problem is either no power or no ground at the injector clip. You now need to use a test light or multimeter to determine whether injector clips have battery voltage with the key in ON(II).
__________________
Don't guess, troubleshoot.
Useful tech links -- FAQs; Codes; Check Spark; Test Fuses; Fuse 15 TSB; Clean IACV or FITV
RonJ@HT is offline   Reply With Quote
 
 
 
submit to reddit
Reply

Tags
1992, 2000, 94, civic, d16y8, fireing, firing, fuel, ground, honda, injector, injectors, number, shoot, triggering, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -8. The time now is 08:29 PM.



2008 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details