1991 Civic DX Fuel Pump/Relay problems - Honda-Tech

Go Back   >
Log In 


1991 Civic DX Fuel Pump/Relay problems

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-22-2007, 09:15 PM   #1
Honda-Tech Member
Thread Starter
 
AllMtrRex's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 843
Default 1991 Civic DX Fuel Pump/Relay problems

I hate the first Post has to be a ? but I'm lost on this one. I don't like asking for help with HONDA problems (I usually just try to fix it or just skim honda-tech for some answers. But i have a 1991 Civic DX, it had a dual cam ZC engine in it before i bought it (so somebody converted it to MultiPoint) Then before the guy sold it the D15b2 went back in.(the engine wiring harness was replaced with a dual point unmodified) Car was fine for almost a year with dual point. Then few days ago went to start it and it started up and idled for about 5 seconds then stalled. I tested the fuel pressure at the filter (the line running from the filter to the fuel rail)Fuel pressure was fluctuating from 0-10psi. So i replaced the fuel pump with a USED fuel pump from a 1991 Crx Si (Crx sit for 6 months but was fine when parked)After i replaced the fuel pump went to start it and nothing happen (check engine light came on normally in auxiliary, but there was no "click" from Main Relay nor a "buzz" from the fuel pump and the check engine light stayed on. But before i replaced the pump with the used one the Main Relay would "click" then the check engine light would go off but the Fuel pump wouldn't prime (no buzz)..Ive double checked the fuses in the underdash fuse box also the ground on the thermostat(read that somewhere)..I only found One hot wire in the wiring for the pump(wiring under the rear seat) it was a yel/wht wire..it was 6.5v..Cant find any info on the wiring voltages for the Pump.....But in my opinion there is a problem between the connector under the rear seat and the Fuel pump itself...sorry for the long post but just wanted to give detailed info on whats goin on..instead of being asked 76376378 questions...Anyone have an idea??(note: Forgot to mention i tried 2 USED Main Relays..(1 came from the Crx Si that was runnning when parked)...
AllMtrRex is offline   Reply With Quote
Old 04-22-2007, 09:56 PM   #2
Honda-Tech Member
Thread Starter
 
AllMtrRex's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 843
Default Re: 1991 Civic DX Fuel Pump/Relay problems (AllMtrRex)

No one has any ideas??? I think i typed to much and people just see alot of words and press back in their browser..heh
AllMtrRex is offline   Reply With Quote
Old 04-23-2007, 07:18 AM   #3
Honda-Tech Member
Thread Starter
 
AllMtrRex's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 843
Default Re: 1991 Civic DX Fuel Pump/Relay problems (AllMtrRex)

Tried a couple more things today..still nothing....someone got some info on this???..would be nice
AllMtrRex is offline   Reply With Quote
Old 04-23-2007, 08:37 AM   #4
Member
 
mahatma's Avatar
 
Join Date: Jan 2005
Location: NKY
Posts: 1,972
Default Re: 1991 Civic DX Fuel Pump/Relay problems (AllMtrRex)

so your pump does not prime at all now? 0psi fuel pressure?

i thought power was fed to the fuel pump via a black/yellow wire. if you're not getting voltage through that, you may have found your problem.

it sucks swapping used parts around, you never really know what's good anymore lol
mahatma is offline   Reply With Quote
Old 04-26-2007, 06:01 PM   #5
Honda-Tech Member
Thread Starter
 
AllMtrRex's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 843
Default Re: 1991 Civic DX Fuel Pump/Relay problems (mahatma)

yeah..fuel pump not priming at all...0psi yes...check engine light doesn't even come on...then off like normal it just stays on..not sure about the black/yel wire powering the fuel pump...I need a helms manual...i have a haynes (crappy for 88-91)...gonna give it another try tomm. been busy all week...sorry for the late post
AllMtrRex is offline   Reply With Quote
Old 04-26-2007, 06:08 PM   #6
Honda-Tech Member
iTrader: (2)
 
nihad's Avatar
 
Join Date: Nov 2006
Location: Waterloo, Iowa
Posts: 3,770
Default

try the relay it has a rz number on it it is called the main relay it is above the hood relese it is not the small relay it is pretty big all so kinda hard to get to.
nihad is offline   Reply With Quote
Old 04-26-2007, 06:26 PM   #7
Honda-Tech Member
Thread Starter
 
AllMtrRex's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 843
Default Re: (nihad)

yeah..i noted that i tried 3 relays...its rz 0063...tried 3 of the same relay and nothing..someone state if it could be this.....when i took the fuel pump out it had plastic housings over the positive and ground on the fuel pump housing.. when i tried to take them off one of the clips that hold them on broke..so i put them on and noticed that they weren't as tight as before...maybe gas is getting in the plastic housings...i would kinda hope not..sounds like there would be a boom if positive or ground were to arc in a gas filled tank???maybe not
AllMtrRex is offline   Reply With Quote
Old 04-27-2007, 03:35 AM   #8
Junior Member
 
charliev's Avatar
 
Join Date: May 2005
Location: Detroit, MI, Wayne
Posts: 143
Default

no it wouldnt cause flame no oxygen when under the gas and the plastic clips i doubt would have anything to do with it my walbro has nothing but a connector to the pemp itself and im pretty sure its not sealed.... anyway On ALLDATA there is a main relay HARNESS test that might be useful just to make sure the wires are good....

cvitullo
charliev is offline   Reply With Quote
Old 04-27-2007, 07:06 AM   #9
Honda-Tech Member
Thread Starter
 
AllMtrRex's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 843
Default Re: (charliev)

ok thanks for the info...will check ALLDATA out..starting again on it today..haven't been able to mess with it for a couple days..should have it fixed..
AllMtrRex is offline   Reply With Quote
Old 04-29-2007, 07:57 PM   #10
Honda-Tech Member
 
Jreycrx's Avatar
 
Join Date: Mar 2007
Location: Junction City, KS, USA
Posts: 30
Default Re: (AllMtrRex)

hey when you find out the problem let me know my buddy has the same problem with his crx its been sittin for like 3 months, we cant figure that **** out!
Jreycrx is offline   Reply With Quote
Old 05-01-2007, 09:21 AM   #11
Honda-Tech Member
Thread Starter
 
AllMtrRex's Avatar
 
Join Date: Apr 2007
Location: NC
Posts: 843
Default Re: (Jreycrx)

finally figured it out....when we replaced the fuel pump with the used (working fuel pump) the banjo nut on the fuel feed line was grounding out on the fuel pump's housings ground wire screw..if you plugged the fuel pump connector under the seat up...then turned the key on it would blow the underdash fuse #14 everytime...(we checked the fuses many times but it would only blow the fuse if the connector was plugged up so when we checked them all the connector was more than likely unplugged and the fuse was still ok)...so we dropped the tank flipped the fuel line 90 degrees (it wouldn't work any other way..dunno) then connected the fuel pump connector...turned the key and the main relay clicked and the fuel pump motor was buzzing...we jacked back up...took about to dry starts to prime the fuel system and it run fine....lot of trial and error..3 hours of being frustrated payed off...
AllMtrRex is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing Main Relay. No Start. Dim ECL Light. cleanM1 Honda Civic / Del Sol (1992 - 2000) 3 05-03-2012 10:31 AM
bad main relay or starter relay? Amberlyscramble Honda CRX / EF Civic (1988 - 1991) 17 12-16-2011 07:31 AM
1992 Civic LX Cranks, No Start T_ypEr Honda Civic / Del Sol (1992 - 2000) 21 03-20-2011 06:31 AM
Fuel pump relay rapid click no start JacksonD Honda CRX / EF Civic (1988 - 1991) 18 01-08-2011 12:34 AM
Fuel Pump not priming, But Main relay clicks! SpoonEk253 Honda Civic / Del Sol (1992 - 2000) 40 04-25-2007 05:50 AM


Tags
90, 91, civic, crx, dx, fuel, gas, harness, multipoint, pump, relay, rz0063, swap, test, underdash, zc

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:09 AM.



Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.