Go Back   Honda-Tech > Honda and Acura Technical Forums > Tech/Misc
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-13-2014, 12:06 AM   #1
Honda-Tech Member
 
Join Date: Mar 2009
Posts: 55
iTrader Rating: (0)
Default car keeps dying on cold start

Engine: B20V 99 B16 HEAD
Since I'm running the Skunk2 Billet Throttle Body, it eliminates fast idle.
So anyways when I start my car in the cold morning, it jumps to 700-900 rpm on cold start (remember no fast idle skunk2 billet tb).
-RPM stays steadily for a good 1-2min once it starts up.
-Then it starts to idle up and down from 400-900rpm.
-It idle roughly and it dies.
-When it dies, I start it back up does same thing until engine actually warms up.
-But if I just drive while engine is cold, engine runs very funny as if timing wasn't correct and it will just lag for a good 1-2 second, and when the lag goes away, it picks right back up being strong again.
-Timing belt and valve adjusted correctly TDC.
As it is completely warmed up, runs like a normal engine, no dying crap.
At first I thought it was maybe a faulty:
1. ECU- Which I tried another ECU and same thing still.
2. Distributor- Tried another, same
3. Spark Plugs- Replaced, same
4. ECT Sensor (Engine Coolant Temp)- Switch all 3, Same
*NO CEL*


Any idea where I should check next? I really need help, I've been stuck for a good 2 months with this issue.
reg_lus is offline   Reply With Quote
Old 02-13-2014, 12:14 AM   #2
Honda-Tech Member
 
Join Date: Dec 2008
Posts: 7,106
iTrader Rating: (0)
Default Re: car keeps dying when start up

I'm no expert on custom setups but I would think if you're running without an fitv you should be using a chipped ecu. The stock ecu is expecting it to be idling higher on a cold startup until it detects the coolant is warm. It's going to run rich on a cold startup however you're not giving it enough air(via fitv operation).
holmesnmanny is offline   Reply With Quote
Old 02-13-2014, 12:15 AM   #3
Honda-Tech Member
 
Join Date: Mar 2009
Posts: 55
iTrader Rating: (0)
Default Re: car keeps dying when start up

I also forgot to mention i'm on base map, neptune
reg_lus is offline   Reply With Quote
Old 02-13-2014, 12:18 AM   #4
Honda-Tech Member
 
Join Date: Mar 2009
Posts: 55
iTrader Rating: (0)
Default Re: car keeps dying when start up

Quote:
Originally Posted by holmesnmanny View Post
I'm no expert on custom setups but I would think if you're running without an fitv you should be using a chipped ecu. The stock ecu is expecting it to be idling higher on a cold startup until it detects the coolant is warm. It's going to run rich on a cold startup however you're not giving it enough air(via fitv operation).
well i took out the skunk2 billet tb and use the stock regular 1 and still did the same thing. also thought it was maybe TPS, but calibration was reading correctly at WOT and close.
reg_lus is offline   Reply With Quote
Old 02-13-2014, 12:21 AM   #5
Honda-Tech Member
 
Join Date: Mar 2009
Posts: 55
iTrader Rating: (0)
Default Re: car keeps dying on cold start

And I just bought a Aem Uego Wide Band. I wanna see where i'm at on cold start...
Do you know what # it should be on a cold start on the wide band?
reg_lus is offline   Reply With Quote
Old 02-13-2014, 01:34 PM   #6
Honda-Tech Member
 
Join Date: Mar 2009
Posts: 55
iTrader Rating: (0)
Default Re: car keeps dying on cold start

bump
reg_lus is offline   Reply With Quote
Old 02-15-2014, 11:09 PM   #7
Honda-Tech Member
 
DCFIVER's Avatar
 
Join Date: Mar 2004
Location: failing a car near you.....
Posts: 3,532
iTrader Rating: (0)
DCFIVER
Default Re: car keeps dying on cold start

Coolant level ok?
__________________
ASE Master/L1 Technician
DCFIVER is offline   Reply With Quote
Old 02-17-2014, 01:50 AM   #8
Honda-Tech Member
 
slowcivic2k's Avatar
 
Join Date: Jul 2006
Location: Illinois
Posts: 2,455
iTrader Rating: (0)
Default Re: car keeps dying on cold start

Fast idle is pretty important in a cold climate, or at least on a cold day. Not having it will bear consequence to your cold performance.

What do your compression numbers reveal, if all else is perfectly serviceable.

I would assume you have checked for an air leak, doesn't seem likely given the good warm performance.

O2 sensors do not work very well when cold, and most computers will ignore them completely (with the exception of the heater circuit bias) until the engine has warmed up at least, partially.
__________________
Retired ASE Master Technician/Advanced Level Specialist
slowcivic2k is offline   Reply With Quote
Old 02-18-2014, 05:19 PM   #9
Honda-Tech Member
 
Join Date: Mar 2009
Posts: 55
iTrader Rating: (0)
Default Re: car keeps dying on cold start

DCFIVER- Yes, Coolant level good.
slowcivic2k- my compression is around 230psi all around. o2 sensor is disable. and i just installed my wide band. cold start i remember it was around high 14s....and when it's going to die, my AFR starts going toward the Lean area (high 16s and mid 17s on AFR)
reg_lus is offline   Reply With Quote
Old 02-18-2014, 05:19 PM   #10
Honda-Tech Member
 
Join Date: Mar 2009
Posts: 55
iTrader Rating: (0)
Default Re: car keeps dying on cold start

I'm thinking not enough Fuel? maybe that could be the problem?
reg_lus is offline   Reply With Quote
Old 02-21-2014, 01:49 PM   #11
Honda-Tech Member
 
Join Date: Dec 2012
Posts: 5
iTrader Rating: (0)
Default Re: car keeps dying on cold start

Yes sounds like lack of fuel to me too
outgunned is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
skunk2 billet no fast idle, hard start on cold start reg_lus Tech/Misc 3 05-12-2014 06:07 AM
Help: *98 Civic B18C...what is it...wrong ecu?* ToTriggerHappy Honda Civic/Del Sol (1992 - 2000) 17 03-06-2011 04:45 PM
b16a cold start issue. help plz 90_integra Acura Integra 1 11-20-2010 01:18 AM
93 del sol: where's the choke knob ? itsmejto Honda Civic/Del Sol (1992 - 2000) 9 11-19-2008 06:10 AM
jdm b16 has been dying but finally died all the way today help!!!!! ElectronBlueGsr1.8 Honda CRX / EF Civic (1988-1991) 2 09-22-2004 06:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Join Honda-Tech.com

All times are GMT -8. The time now is 10:53 PM.



2014 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details