Go Back   Honda-Tech > Honda and Acura Model-Specific Technical Forums > Honda Civic/Del Sol (1992 - 2000)
Sign in using an external account
Register Forgot Password?
Search


Welcome to Honda-Tech!
Welcome to Honda-Tech.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Honda-Tech community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
Old 10-25-2011, 05:02 PM   #1
Ek Steve
Honda-Tech Member
Garage is empty, add now
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Turn Signals not working

My turn signals work one min. then don't work the next. They started messing up after I hit the hazard lights button. It chooses when to work.
Ek Steve is offline   Reply With Quote
Old 10-25-2011, 05:32 PM   #2
sde780
Honda-Tech Member
Garage is empty, add now
 
sde780's Avatar
 
Join Date: Dec 2007
Location: Morgantown, WV, USA
Posts: 4,579
iTrader Rating: (0)
Send a message via AIM to sde780
Default Re: Turn Signals not working

Check fuses, make sure one of the bulbs isn't burnt/starting to fail
__________________
2012 Tacoma DCLB
https://www.youtube.com/user/shengdama?feature=mhee
sde780 is offline   Reply With Quote
Old 10-25-2011, 06:10 PM   #3
Slacker93eg
Honda-Tech Member
1993 Honda Civic
 
Slacker93eg's Avatar
 
Join Date: Apr 2011
Location: Chicago
Posts: 800
iTrader Rating: (0)
IR_Slacker
Default Re: Turn Signals not working

Mines doing the same thing, all the sockets wiring is screwed up.
__________________
93 Honda Civic Hatchback
LSVtec Turbo Build
Check out RC Autoworks
Slacker93eg is offline   Reply With Quote
Old 10-25-2011, 06:22 PM   #4
Ek Steve
Honda-Tech Member
Garage is empty, add now
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Re: Turn Signals not working

Quote:
Originally Posted by Slacker93eg View Post
Mines doing the same thing, all the sockets wiring is screwed up.
Do the turn signal lights blink on the dash when the blinkers aren't working? Mine doesn't show up at all and it makes a noise like they are on, but they aren't.
Ek Steve is offline   Reply With Quote
Old 10-25-2011, 07:01 PM   #5
vinem1
Honda-Tech Member
Garage is empty, add now
 
Join Date: Oct 2011
Location: Orange,So Cal
Posts: 69
iTrader Rating: (0)
Default Re: Turn Signals not working

The same thing happened to me when i replace my radio unit , i forgot to plug back the hazard lights button, if all your fuses and wires are correct take a look at it. or maybe is just a fuse .
vinem1 is offline   Reply With Quote
Old 10-25-2011, 07:24 PM   #6
EJ2B16
Honda-Tech Member
Garage is empty, add now
 
EJ2B16's Avatar
 
Join Date: Oct 2011
Location: cali
Posts: 39
iTrader Rating: (0)
Default Re: Turn Signals not working

same problem with my civic!!!!
i have to turn my blinkers 10sec before i want to turn and all of a sudden they work. dont know what it is. any help?. its not the fuses its not the bulbs....

http://thehid-spot.webs.com/
http://thehid-spot.webs.com/
http://thehid-spot.webs.com/

Last edited by EJ2B16; 03-04-2012 at 11:15 PM.
EJ2B16 is offline   Reply With Quote
Old 10-25-2011, 08:44 PM   #7
sde780
Honda-Tech Member
Garage is empty, add now
 
sde780's Avatar
 
Join Date: Dec 2007
Location: Morgantown, WV, USA
Posts: 4,579
iTrader Rating: (0)
Send a message via AIM to sde780
Default Re: Turn Signals not working

Quote:
Originally Posted by Ek Steve View Post
Do the turn signal lights blink on the dash when the blinkers aren't working? Mine doesn't show up at all and it makes a noise like they are on, but they aren't.
So the relay clicks but there's no light? Did you check the bulbs?
__________________
2012 Tacoma DCLB
https://www.youtube.com/user/shengdama?feature=mhee
sde780 is offline   Reply With Quote
Old 10-25-2011, 08:52 PM   #8
Ek Steve
Honda-Tech Member
Garage is empty, add now
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Re: Turn Signals not working

Quote:
Originally Posted by sde780 View Post
So the relay clicks but there's no light? Did you check the bulbs?
yes and when it is working the turn signals show up on my dash so it cant be the bulbs
Ek Steve is offline   Reply With Quote
Old 10-25-2011, 09:25 PM   #9
RonJ@HT
Raising the bar
2000 Honda Civic
My Garage
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,249
iTrader Rating: (0)
Default Re: Turn Signals not working

Pry the hazard lights switch out of the dash and check whether the connector is not fully seated on the switch.
__________________
Don't guess, troubleshoot.
Useful tech links -- FAQs; Codes; Check Spark; Test Fuses; Fuse 15 TSB; Clean IACV or FITV
RonJ@HT is offline   Reply With Quote
Old 10-26-2011, 03:48 PM   #10
Ek Steve
Honda-Tech Member
Garage is empty, add now
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Re: Turn Signals not working

it was the hazards, its fixed now thanks guys. oh and does anyone know why my blinker switch doesn't click off when i turn( i have a momo steering wheel if that helps). Thanks!
Ek Steve is offline   Reply With Quote
Old 10-28-2011, 07:02 PM   #11
vinem1
Honda-Tech Member
Garage is empty, add now
 
Join Date: Oct 2011
Location: Orange,So Cal
Posts: 69
iTrader Rating: (0)
Default Re: Turn Signals not working

You probably need to replace the blinker switch or try to clean it and check the cables.
vinem1 is offline   Reply With Quote
 
 
 
submit to reddit
Reply

Tags
93, blinkers, civic, del, dont, ep3, honda, kswap, signal, signals, sol, stopped, turn, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -8. The time now is 12:53 PM.



2008 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details