Go Back   Honda-Tech > Honda and Acura Model-Specific Technical Forums > Honda Civic/Del Sol (1992 - 2000)
Sign in using an external account
Register Forgot Password?
Search


Welcome to Honda-Tech!
Welcome to Honda-Tech.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Honda-Tech community today!


Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
Old 01-06-2009, 04:13 PM   #1
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default FAILED inspection - twice for same thing [OBD not ready]

97 ex coupe

I went for an inspection 2 weeks ago, shorty after changing my 02 sensor on my cat [myself]. i disconnected the battery and changed it because my check engine light was on. it is currently not on anymore after changing it. I have not noticed a difference in driving/performance/mpg.

I went for an inspection after driving about 200 miles. it failed because the OBD was not ready to transmit emissions ect.. yada yada, so i drive another 350 miles and I went again today and I failed again for the same problem.


What the hell? and all I hear is "keep driving." apparently 600 miles after disconnecting the battery isn't enough?


help/suggestions appreciated.

Good lookin HT
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-06-2009, 04:25 PM   #2
Honda-Tech Member
 
ekb16's Avatar
 
Join Date: Feb 2005
Location: ca
Posts: 2,688
iTrader Rating: (1)
Send a message via AIM to ekb16
Default Re: FAILED inspection - twice for same thing [OBD not ready]

ur readiness monitors hasnt set to COMPLETE/READY yet...there is certain driving conditions u have to do to enable ur monitors..try doing this:

1.start ur car when it cold
2.let it idle until the radiator fan comes on 1x
3. drive it between the speeds of 25-60mph for at least 6 miles without any abrupt acceleration

that SHOULD enable the last 2 or 3 monitors u have left..if not there is something wrong and u would need to fix
__________________
B.A.R. member as of 3/18/09 JDM gsr in 98 hatch
Voches: chickwithastick,93allmotorcoupe,jomama,punoy69,Tom theman70
ekb16 is offline   Reply With Quote
Old 01-06-2009, 04:38 PM   #3
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Is there a way that I can manually check this? that is.. without taking it back to the shop to have the process repeated?
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-06-2009, 04:51 PM   #4
Honda-Tech Member
 
ekb16's Avatar
 
Join Date: Feb 2005
Location: ca
Posts: 2,688
iTrader Rating: (1)
Send a message via AIM to ekb16
Default Re: FAILED inspection - twice for same thing [OBD not ready]

if u can find a scanner that reads readiness codes...take it to ur local dealership and ask if u can have a technician plug in a scanner and see how many readiness codes are set..some dealership might be nice enough and not charge u but some can be dicks and make u pay for it..
__________________
B.A.R. member as of 3/18/09 JDM gsr in 98 hatch
Voches: chickwithastick,93allmotorcoupe,jomama,punoy69,Tom theman70
ekb16 is offline   Reply With Quote
Old 01-06-2009, 05:00 PM   #5
Honda-Tech Member
 
EG_Warped's Avatar
 
Join Date: Aug 2006
Location: three3six USA
Posts: 241
iTrader Rating: (0)
Send a message via AIM to EG_Warped
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Quote:
Originally Posted by ekb16 View Post
if u can find a scanner that reads readiness codes...take it to ur local dealership and ask if u can have a technician plug in a scanner and see how many readiness codes are set..some dealership might be nice enough and not charge u but some can be dicks and make u pay for it..
I am in NC and the Advance Auto here does that service for free...
__________________
I WANT YOUR BLACK EG INTERIOR PARTS!!
EG_Warped is offline   Reply With Quote
Old 01-06-2009, 05:32 PM   #6
Honda-Tech Member
 
ekb16's Avatar
 
Join Date: Feb 2005
Location: ca
Posts: 2,688
iTrader Rating: (1)
Send a message via AIM to ekb16
Default Re: FAILED inspection - twice for same thing [OBD not ready]

even better
__________________
B.A.R. member as of 3/18/09 JDM gsr in 98 hatch
Voches: chickwithastick,93allmotorcoupe,jomama,punoy69,Tom theman70
ekb16 is offline   Reply With Quote
Old 01-06-2009, 05:41 PM   #7
Honda-Tech Member
 
gsrhatch2356's Avatar
 
Join Date: Dec 2006
Location: DFW, tx, usa
Posts: 990
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

yea if I were you I would go get them checked before you turn the car off and then turn the car off and check again. I had a car that the 12v memory to the computer was bad so everytime she shut the car off all the monitiors would reset. I know this much i drive alot of cars to get them into rediness and hondas are one of the easier ones to set. I dont know about your state law but in texas you can have 2 not readys if it is 00 and older and 1 not ready if it is 01 and newer.
__________________
well, times have changed and unfourtantly I need some money so the project has to go. maybe another time.
gsrhatch2356 is offline   Reply With Quote
Old 01-06-2009, 05:57 PM   #8
Honda-Tech Member
 
saywhat's Avatar
 
Join Date: Nov 2004
Posts: 1,329
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Quote:
Originally Posted by gsrhatch2356 View Post
I had a car that the 12v memory to the computer was bad so everytime she shut the car off all the monitiors would reset.
I had the same problem, replaced the fuse for the ecu/radio under the hood and it passed after a few (10) miles of driving.
__________________
Quote:
Originally Posted by George Knighton View Post
Oh, I am sorry. I didn't realise it was a woman.
Quote:
Originally Posted by Archidictus View Post
don't do anything to diminish the look, size or feel of "the D".
saywhat is offline   Reply With Quote
Old 01-06-2009, 07:34 PM   #9
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Lots of good info guys, thanks.

Ill post up tomorrow when I figure this out. I might pick up a primary 02 sensor just in case, I don't have any record of it being changed and the motor has been sluggish for months.. even after a full tune up, didnt seem to help, but w/e sohc turbo on its way.
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-09-2009, 01:33 PM   #10
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

damnit, still nothing.


this morning I drove on the highway in the right lane sitting at 55mph for 15 straight miles, turned around, and came back in the same manner... chilled for a while then used an OBD II autoscanner from advanced auto parts, locally and it passes with no codes, but the readiness moniters are still not set yet. wtf? so after talking to some d-bag behind the counter he recommended to change the 15amp fuse for the ecu to give it a "master reset". so I did, just 5 minutes ago.


so we'll see how this plays out, more to come..
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-12-2009, 10:03 AM   #11
Honda-Tech Member
 
ekb16's Avatar
 
Join Date: Feb 2005
Location: ca
Posts: 2,688
iTrader Rating: (1)
Send a message via AIM to ekb16
Default Re: FAILED inspection - twice for same thing [OBD not ready]

how many monitors are READY and how many are NOT READY? if all of them are not set then there is a blown fuse somewhere...3 of ur monitors should already be set everytime u start the car and 2 or 3 should be NOT READY and those r the ones u need to set to COMPLETE..

everytime u reset the ecu/unplug the battery it will reset all ur monitors and u would have to set them again
__________________
B.A.R. member as of 3/18/09 JDM gsr in 98 hatch
Voches: chickwithastick,93allmotorcoupe,jomama,punoy69,Tom theman70
ekb16 is offline   Reply With Quote
Old 01-12-2009, 10:07 AM   #12
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,694
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Quote:
Originally Posted by ^XpLiCiTxX^ View Post
...he recommended to change the 15amp fuse for the ecu to give it a "master reset".
Also check whether this 15A BACKUP fuse is blown.
RonJ@HT is offline   Reply With Quote
Old 01-12-2009, 10:21 AM   #13
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Quote:
Originally Posted by RonJ@HT View Post
Also check whether this 15A BACKUP fuse is blown.
I changed this fuse last night when I called my local dealership. they said if its blown it won't store anything for the next ignition fire. So I did this and he claimed by 100 miles of easy driving, everything should set right.


I'm gonna check again tomorrow with the OBD II Autoscanner from Advanced auto parts and I'll record the info on it and I'll post up here when I come back home.
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-12-2009, 10:24 AM   #14
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,694
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

It's also possible that there is an open in the BACKUP fuse circuit.
RonJ@HT is offline   Reply With Quote
Old 01-12-2009, 10:59 AM   #15
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

elaborate please?
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-12-2009, 11:01 AM   #16
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,694
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

A broken wire in the circuit would be equivalent to a blown BACKUP fuse or removal of the BACKUP fuse.
RonJ@HT is offline   Reply With Quote
Old 01-12-2009, 11:29 AM   #17
Honda-Tech Member
 
v8 integra's Avatar
 
Join Date: Sep 2004
Posts: 519
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

i had the same problem...i have a scanner that read readiness test and i had it plugged in while i drove to school and back and 2 of my readiness were ready in about 40 miles...went to the dmv and passed....also if ur from nj the dmv allows 2 readiness tests to not b ready...good luck
__________________
96 civic ex JDM b16 swap.. RIP http://is.rely.net/1-92-65076-l-NREc...mLFY3DaZnA.gif n then brought back to life http://images.honda-tech.com/set1/smile/emsmile.gif
DC sport headers
N1 apexi cat back exhaust
v8 integra is offline   Reply With Quote
Old 01-13-2009, 01:20 PM   #18
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

For the third damn time... it's still not ready yet. wtf??

I wrote down everything that the autoscanner had in text on the screen so here it is.


MIL Lamp should be OFF if engine is running


Misfire moniter OK
Fuel system mon OK
Comp Component OK
Catalyst Mon Inc
Hid catalyst N/A
Evap system mon Inc
Sec Air system N/A
A/C Refrig Mon N/A
Oxygen sens Mon Inc
Oxygen Sens Htr OK
EGR system Mon N/A


That's everything. I changed out the 15A fuse for the ECU under the hood about 4 days ago and I've driven around.. 150 - 175 miles since then.


I have an appt that I really would like to cancel at Honda for tomorrow morning at 9am. the dealership says it will be $102 minimum to diagnose the problem, and that doesn't include cost to fix anything that could be wrong. So I don't know what to do, but I need to defend a ticket from a trooper and I'm over 3 weeks late on it because of this ****. Help me out

Thanks HT
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-13-2009, 01:31 PM   #19
Junior Member
 
snoopiie's Avatar
 
Join Date: Feb 2007
Location: ca
Posts: 87
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

and i think us Californians have problems with smog hahaa..
__________________
95 Integra GS-R
snoopiie is offline   Reply With Quote
Old 01-13-2009, 01:31 PM   #20
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,694
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

The stereo and heater control panel are also protected by the 15A BACKUP fuse. Do they work?

Does the CEL stay ON when the ignition key is turned to ON(II) or does it turn OFF after 2 seconds?

Does the CEL stay ON steady when you jump the service connector or does it turn OFF?
RonJ@HT is offline   Reply With Quote
Old 01-13-2009, 01:43 PM   #21
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Quote:
Originally Posted by RonJ@HT View Post
The stereo and heater control panel are also protected by the 15A BACKUP fuse. Do they work?

Does the CEL stay ON when the ignition key is turned to ON(II) or does it turn OFF after 2 seconds?

Does the CEL stay ON steady when you jump the service connector or does it turn OFF?

The radio doesn't work, but I have an in-dash tv and it works fine, cept for radio, which I never use because I have an ipod hookup. The heater control panel works, yes.

The CEL light stays on for 2 seconds and goes away.

When I jumped the service connector, it gave me the code for the secondary 02 sensor, which I replaced with a Denso direct replacement sensor. I did the job myself and I know I didn't mess it up. lol
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-13-2009, 01:46 PM   #22
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,694
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Quote:
Originally Posted by ^XpLiCiTxX^ View Post
When I jumped the service connector, it gave me the code for the secondary 02 sensor, which I replaced with a Denso direct replacement sensor. I did the job myself and I know I didn't mess it up. lol
Does the CEL now stay ON steady when you jump the service connector or does it turn OFF?
RonJ@HT is offline   Reply With Quote
Old 01-13-2009, 02:05 PM   #23
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Turns off normally.
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
Old 01-13-2009, 02:08 PM   #24
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 34,694
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

Quote:
Originally Posted by ^XpLiCiTxX^ View Post
Turns off normally.
With the service connector jumped, the CEL should stay ON steady if there are no codes stored in the ECU. Your ECU might be bad or the service connector circuit has an open.
RonJ@HT is offline   Reply With Quote
Old 01-13-2009, 02:09 PM   #25
Honda-Tech Member
 
^XpLiCiTxX^'s Avatar
 
Join Date: Mar 2008
Location: Westchester, New York, United States
Posts: 1,325
iTrader Rating: (0)
Default Re: FAILED inspection - twice for same thing [OBD not ready]

mother of god
__________________
-Vouches: Mr. EM1, Gregmatic, themouse, Mr. Marcin, b63phatch,
terqui, killerpenguin21, delsoldreams, mikeymcm!, b16racereg6
WTB: 94-97 integra front+rear bumper (silver pls)!
^XpLiCiTxX^ is offline   Reply With Quote
 
 
 
submit to reddit
Reply

Tags
97, cat, civic, fail, im, inspection, ma, massachusetts, monitor, o2s, obd, ready, rules, sensors, twice

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Civic EX COUPE, FAIL... otherink Honda Civic (2006 - Current) 11 01-19-2014 04:31 PM
2006 civic EX coupe, fail... otherink Tech/Misc 7 01-19-2014 11:20 AM
Re-learn? 1990 accord 89dxcivic Honda Accord (1990 - 2002) 5 01-03-2013 02:05 PM
2006 CRV SE showing ODB2 "Not Ready" Reapermen Ridgeline : MDX : Odyssey : Pilot : RDX 5 07-30-2009 02:10 AM
Failed Smog Check: Function Test error. Emissions were fine. Need some help here! undertheradar Honda Civic/Del Sol (1992 - 2000) 6 10-18-2004 02:45 PM



All times are GMT -8. The time now is 08:50 AM.



2014 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details