Go Back   Honda-Tech > Honda and Acura Model-Specific Technical Forums > Honda Civic/Del Sol (1992 - 2000)
Sign in using an external account
Register Forgot Password?
Search


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-09-2011, 06:06 PM   #1
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Icon2 *Sloved* 93 Civic Stalls... chasing problem... please help!

My girls 93 Civic dies while driving sometimes, coming to a stop, and even when just idling in park, warming up in the morning.

Recent repairs: Over this past summer it had a similar issue. I replaced the ICM and the coil and did not have any problems until recently.

Recent symptoms: It died on her 5 times within a half hour or so today. She was able to make it to where I work and she took my car home. I drove the civ home... was fine while it was cold... about 15 mins later it surged/misfired a few times and died... put it in neutral and restarted... died immediately after restarting... started again and ran fine but CEL came on. Died one more time 10 mins later... got home and put it in park... died. Restarted and went in side to get a jumper to pull code... came out and it had died... still jumped it anyways and got one quick flash... which is for O2 #1, I think.

I am not sure if I should replace the ICM again... I didn't think an O2 sensor would cause it to act up this badly... maybe wrong though.

Here are my choice... not sure what to try first:
ICM
Coil
Main Relay
O2 Sensor

This thing is kicking my ***... I could use some advice right now befor it gets the BFH and torched!

Thanks in advance!!!!

Last edited by TimFields45; 02-19-2011 at 09:41 AM. Reason: Sloved problem
TimFields45 is offline   Reply With Quote
Old 02-09-2011, 10:07 PM   #2
Honda-Tech Member
 
Join Date: Jul 2010
Posts: 53
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by TimFields45 View Post
My girls 93 Civic dies while driving sometimes, coming to a stop, and even when just idling in park, warming up in the morning.

Recent repairs: Over this past summer it had a similar issue. I replaced the ICM and the coil and did not have any problems until recently.

Recent symptoms: It died on her 5 times within a half hour or so today. She was able to make it to where I work and she took my car home. I drove the civ home... was fine while it was cold... about 15 mins later it surged/misfired a few times and died... put it in neutral and restarted... died immediately after restarting... started again and ran fine but CEL came on. Died one more time 10 mins later... got home and put it in park... died. Restarted and went in side to get a jumper to pull code... came out and it had died... still jumped it anyways and got one quick flash... which is for O2 #1, I think.

I am not sure if I should replace the ICM again... I didn't think an O2 sensor would cause it to act up this badly... maybe wrong though.

Here are my choice... not sure what to try first:
ICM
Coil
Main Relay
O2 Sensor

This thing is kicking my ***... I could use some advice right now befor it gets the BFH and torched!

Thanks in advance!!!!
if the coil and ignitor is under warranty id just swap it all out and put a o2 sensor in it and call it a day. get a universal o2 and just splice the wires together they are about half the price of ones with the plug already on them..
jdmshawn95 is offline   Reply With Quote
Old 02-10-2011, 06:41 PM   #3
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

So I just ended up ordering the ICM, Coil, O2, and Main Relay today. All together its was $210 with shipping. I would rather just get the O2 and Main Relay also just to make sure they aren't bad or will go bad soon. Haven't had to put much in it since I bought it, so I don't mind... just tired of trying to find a prob that last for 1-2 seconds when it happens..
TimFields45 is offline   Reply With Quote
Old 02-10-2011, 06:46 PM   #4
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,780
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Does unplugging the O2 sensor eliminate the problem?
__________________
Don't guess, troubleshoot

Technical links:
FAQs sticky...CEL Codes...Spark diagnosis...
Testing Fuses...Fuse 15 TSB...Cleaning the IACV or FITV

92-00 Civic Forum Rules
RonJ@HT is offline   Reply With Quote
Old 02-11-2011, 05:55 AM   #5
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by RonJ@HT View Post
Does unplugging the O2 sensor eliminate the problem?
Haven't yet but I will try before I replace anything... good idea. I am sure it will trip a DTC but thats easily cleared. O2 makes the most sense to me... b/c when its really cold in closed loop it runs fine... as soon as it warms up... thats when its starts acting up.
TimFields45 is offline   Reply With Quote
Old 02-11-2011, 11:21 AM   #6
Honda-Tech Member
 
EFPhilly's Avatar
 
Join Date: Feb 2009
Location: Salem, Oregon
Posts: 816
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Clean that IACV too did not see you state you did that...But you need to fix that CEL. If still stalling after fixed then Idle related component (IACV, FITV)
__________________
Precision T3/T67 H.O. powered forged GSR/B16 1993/98 vx hatch.
Quote:
Originally Posted by 99civichx View Post
no antifreeze in the radiator...im guessin thats a major problem correct...
“Mind so sharp, I f*ck around and cut my head off.” -Lil Wayne
EFPhilly is offline   Reply With Quote
Old 02-11-2011, 06:00 PM   #7
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by EFPhilly View Post
Clean that IACV too did not see you state you did that...But you need to fix that CEL. If still stalling after fixed then Idle related component (IACV, FITV)
Yup... IACV cleaning is on the list as well. I am just going to do it all at one time (O2, Coil, ICM, Main Relay, and clean the IACV and FITV).

As for the CEL... it just came on for the first time last night (first time since I have owned this Civic actually). This problem has been going on for a month or so now.

Had 2 swapped civs and an accord... never had probs with any... this one is just being a pain.
TimFields45 is offline   Reply With Quote
Old 02-11-2011, 07:55 PM   #8
Honda-Tech Member
 
ownedevo10's Avatar
 
Join Date: May 2010
Posts: 225
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

You can also try changing the fuel filter.. I had a similar problem about a month ago and I changed the fuel filter and the stalling down in low rpms went away.. It was only like 8 bucks so its worth a shot..
ownedevo10 is offline   Reply With Quote
Old 02-12-2011, 06:10 AM   #9
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by ownedevo10 View Post
You can also try changing the fuel filter.. I had a similar problem about a month ago and I changed the fuel filter and the stalling down in low rpms went away.. It was only like 8 bucks so its worth a shot..
Good idea... by the time I am done its gonna be like a restoration project haha. Its all good though... I want my girl to have a reliable car.
TimFields45 is offline   Reply With Quote
Old 02-12-2011, 08:02 AM   #10
Honda-Tech Member
 
Join Date: Aug 2010
Location: midlands of south carolina
Posts: 267
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

how long ago since last tune up?
__________________
95 honda civic with 96 b18c
vitamin_c95 is offline   Reply With Quote
Old 02-12-2011, 08:28 AM   #11
Honda-Tech Member
 
ownedevo10's Avatar
 
Join Date: May 2010
Posts: 225
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Keep this thread updated to find out what happens..
ownedevo10 is offline   Reply With Quote
Old 02-12-2011, 10:53 AM   #12
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by vitamin_c95 View Post
how long ago since last tune up?
Over the summer... the first time I replaced the Coil and ICM... did cap, rotor, wires, plugs, air filter, and PCV also. I take good care of my cars (I know you where just asking, not accusing)... don't think its a lack of maintenance... just a failed part.

Quote:
Originally Posted by ownedevo10 View Post
Keep this thread updated to find out what happens..
Will do. I am going to do one part at a time until its fixed... I'll keep it updated
TimFields45 is offline   Reply With Quote
Old 02-14-2011, 05:09 PM   #13
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Parts have arrived... will let everyone know how it goes!
TimFields45 is offline   Reply With Quote
Old 02-19-2011, 09:33 AM   #14
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Well... this morning I pulled out the distributor and replaced the ICM and Coil. It ran fine for about 45 mins without stalling... before it would run 5 mins at a time before stalling. I have yet to replace the Main Relay and O2 sensor. I am still replacing them anyways... more for preventative maintenance... and the fact that I have them right here.

So as for now I am calling this one solved!
TimFields45 is offline   Reply With Quote
Old 02-19-2011, 11:21 AM   #15
Honda-Tech Member
 
Hondatherdm's Avatar
 
Join Date: Jun 2009
Location: CCCP
Posts: 277
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

i think its bad dizzy
Hondatherdm is offline   Reply With Quote
Old 02-19-2011, 11:48 AM   #16
Honda-Tech Member
 
ken9's Avatar
 
Join Date: Nov 2008
Location: Ontario, Kanada
Posts: 1,807
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

What was the problem? I guessing the Dizzy or main relay that can cause a car to stall.
__________________
Quote:
Originally Posted by sstig13 View Post
Gotham City needs you Batman! Quick to the Bat mobile!
Quote:
The Land of Snow and SALT.. OUch!
ken9 is offline   Reply With Quote
Old 02-19-2011, 07:24 PM   #17
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by Hondatherdm View Post
i think its bad dizzy
Quote:
Originally Posted by ken9 View Post
What was the problem? I guessing the Dizzy or main relay that can cause a car to stall.
Yeah it was either the ICM or Coil. I just replaced both of them... as explained in above posts. Runs fine with no stalling now. I replaced the ICM and Coil over the summer with cheap NAPA parts for a similar problem... this time I got better ones. All is well now.
TimFields45 is offline   Reply With Quote
Old 02-20-2011, 11:17 AM   #18
Honda-Tech Member
 
EFPhilly's Avatar
 
Join Date: Feb 2009
Location: Salem, Oregon
Posts: 816
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by TimFields45 View Post
Yeah it was either the ICM or Coil. I just replaced both of them... as explained in above posts. Runs fine with no stalling now. I replaced the ICM and Coil over the summer with cheap NAPA parts for a similar problem... this time I got better ones. All is well now.
__________________
Precision T3/T67 H.O. powered forged GSR/B16 1993/98 vx hatch.
Quote:
Originally Posted by 99civichx View Post
no antifreeze in the radiator...im guessin thats a major problem correct...
“Mind so sharp, I f*ck around and cut my head off.” -Lil Wayne
EFPhilly is offline   Reply With Quote
Old 02-20-2011, 12:05 PM   #19
Honda-Tech Member
 
ReDHaTcHyGuy's Avatar
 
Join Date: Sep 2004
Location: Hagerstown, MD
Posts: 2,148
iTrader Rating: (0)
USG tigersblood Dramer77
Send a message via AIM to ReDHaTcHyGuy
Default Re: 93 Civic Stalls... chasing problem... please help!

have u changed the PVC valve?
__________________
96 EX Coupe
07 FBP Si - Current- FG Squad member #85
97 JDM GSR Hatch-Wrecked
ReDHaTcHyGuy is offline   Reply With Quote
Old 02-20-2011, 02:55 PM   #20
Honda-Tech Member
 
Join Date: Feb 2011
Posts: 10
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

Quote:
Originally Posted by ReDHaTcHyGuy View Post
have u changed the PVC valve?
Yes over the summer during major tune up... stalling problem was solved as stated in above posts.
TimFields45 is offline   Reply With Quote
Old 04-07-2011, 05:35 PM   #21
Trial User
 
Join Date: Apr 2011
Posts: 2
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

I am having a similar problem and I have replaced Rotor, Cap, Main Relay, Fuel pump, fuel filter, spark plugs, and wires. The problem still persists, just random dying of the motor, it only seems to do it when very wet and rainy outside or if I rev the car super hard then it feels like it miss fires then dies.

I am curious if there is anything else I should change when doing the ICM and coil as I am super sick of this problem as it has been happening to me the past year since I bought the car.
delphis is offline   Reply With Quote
Old 04-24-2011, 11:18 AM   #22
Trial User
 
Join Date: Apr 2011
Posts: 2
iTrader Rating: (0)
Default Re: 93 Civic Stalls... chasing problem... please help!

anyone?
delphis is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Car won't start Kasten Acura Integra 4 02-17-2014 12:06 AM
'91 Accord - distributor/speedo? bcaslow Honda Accord & Crosstour (2003 - Current) 1 07-10-2012 08:18 AM
Need all OG'S help with this one!!!!!! Car stalling out of no where. mikeycivic Honda Civic/Del Sol (1992 - 2000) 137 04-20-2010 03:18 PM
95 Civic EX Car dies while driving.... delsol21061 Honda Civic/Del Sol (1992 - 2000) 5 10-02-2008 04:27 PM
Bad distributor or ICM ? She ran, then she died...HELP !! X2BOARD Forced Induction 6 08-06-2002 08:38 AM


Tags
1992, 1993, 93, accord, civic, cold, dies, filter, fuel, good, handa, honda, idle, runs, stalls, symptons, warms

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Join Honda-Tech.com

All times are GMT -8. The time now is 10:39 PM.



2014 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details