H series 99 hatch need help! - Honda-Tech - Honda Forum Discussion


Hybrid / Engine Swaps Discussions about non-stock engine swaps into Honda cars. This is not a forum for hybrid gas/electric cars.
Sponsored by:
Sponsored by:

H series 99 hatch need help!

Reply
 
 
 
Thread Tools Search this Thread
Old 03-05-2017, 01:26 AM   #1
Honda-Tech Member
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Default H series 99 hatch need help!

Hey everyone I'm new here, for starters, I bought this car as a road race project and then life happened and now it's my daily. First issue I had, blew the balance shaft, replaced it with the timing belt and water pump as well. The day I got it running again I got some bad gas.... Plugged the filter, so my dad and I changed it and dumped some fuel system cleaner in it. Then the screw that holds the rotor inside the cap came out, replaced all that mess. Well the car runs decent above 4k rpm, I'm guessing only because vtech is engaged. But under 4k it runs like crap, luggs and pings and has no power or throttle response. Any advice out there? And again, I opoligize on the specifics, I'm new lol
Ace99 is offline   Reply With Quote
Old 03-05-2017, 08:24 AM   #2
Honda-Tech Member
 
Join Date: Apr 2014
Posts: 299
Default Re: H series 99 hatch need help!

The specifics are important here. If it was an "unfinish project" you should check tuning and programing. Most probable is that you have something like Crome or Hondata and doesn't have it tuned.

Take to a tuner to have him a look...
gmcuajo1 is offline   Reply With Quote
Old 03-05-2017, 08:39 AM   #3
Honda-Tech Member
Thread Starter
 
Join Date: Mar 2017
Posts: 2
Default Re: H series 99 hatch need help!

Alright on the specifics, the car was running great when I got it. Not sure what tuning or programming it has. It's a 99 civic hatch with a h22a, iv done the typical mods cold air header exhaust, new plugs, electric fan. No power steering or ac. And recently put a new o2 in it. And magically one day it just started running terrible under vtech rpms and slow cruising. Also when slowing down under braking and down shifting the car bubbles and pops out of the exhaust, not quite like a backfire. Started doing this gradually and I assumed it was from all the dings and dents in the exhaust from bottoming out.
Ace99 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
99 coupe gas tank...what fits.... bandit67 Honda Civic / Del Sol (1992 - 2000) 1 11-30-2016 06:39 AM
Car won't go in gear!! Richief12 Transmission & Drivetrain 6 03-18-2016 08:03 AM
2000 prelude, intermittent dying please help Jason Wells Honda Prelude 2 11-15-2015 03:11 PM
New member, First GSR and a Question 99TeggyGSR Acura Integra 19 01-24-2013 10:22 PM
Expensive education about non-OEM parts 52wrench Classic Hondas 6 01-09-2010 03:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -8. The time now is 02:50 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: