Hybrid / Engine Swaps Discussions about non-stock engine swaps into Honda cars. This is not a forum for hybrid gas/electric cars.
Sponsored by:
Sponsored by:

D16Y8 in EG swap, VTEC not working

 
Old 01-03-2018, 06:22 PM
  #1  
Honda-Tech Member
Thread Starter
 
Join Date: Nov 2017
Posts: 10
Icon5 D16Y8 in EG swap, VTEC not working

Please move this if it is in the wrong place, I am new to this.

I recently purchased a 1993 civic with a D16Y8 and P28 ECU and vtec was working with no CEL. I noticed that the 2 pin pressure switch didn't have a connector so I got one and plugged it in and decided to do the wiring correctly as he had it going across the strut tower and I wanted to run it through the firewall.. I checked the ECU wiring and found that he had pins A4 and D6 connected and only going to the vtec solenoid. I redid the wiring and started it up and the CEL came on so I jumped the blue diagnostic connector and got code 21. I tried reverting back to the way he had it wired (he had it without pins in the ecu connectors, just wires and I kept the pins in.)and it still came up with the CEL after leaving the ECU unplugged for a few minutes. I have confirmed that the Solenoid is working(I heard it clicking when I applied 12v to it) but I still have the CEL after this. I am at a loss on what to do, but I am wondering if the pressure switch is faulty because he had it hooked up like that. Any help would be greatly appreciated, thanks!


This is how I wired the VTEC in, please correct me if this is wrong.


This is how he had it hooked up.'

Thank you very much for your time.
Bheriya is offline  
Old 01-03-2018, 08:15 PM
  #2  
Honda-Tech Member
Thread Starter
 
Join Date: Nov 2017
Posts: 10
Default Re: D16Y8 in EG swap, VTEC not working

Update on some information:
When I was putting the motor in I did not connect the VTEC Solenoid and didn't pop a CEL
I have verified that the screen is not clogged and the oil is full and clean(it is a brand new motor)
The wiring is soldered securely and has good contact
I do not know where it redlines or if it activates VTEC because I am still breaking in my motor
I am starting to think it may be my ECU since it happened the first time I unplugged it? I don't know I am confused with this.
Bheriya is offline  
Old 01-04-2018, 08:52 PM
  #3  
Honda-Tech Member
Thread Starter
 
Join Date: Nov 2017
Posts: 10
Default Re: D16Y8 in EG swap, VTEC not working

Update:
I figured out what was causing this issue. The pins on the ecu were not touching the pins on the harness, I bent the pins on the ecu down a slight bit so they would make contact and CEL went away!
If you are wiring VTEC in a swap make sure the pins are touching.
Bheriya is offline  
Old 01-06-2018, 03:01 AM
  #4  
Honda-Tech Member
 
tony_2018's Avatar
 
Join Date: Nov 2005
Location: Austin, Tx
Posts: 12,671
Default Re: D16Y8 in EG swap, VTEC not working

good job on diagnosing.
tony_2018 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NONvtecLSteg
Acura Integra
1
03-20-2014 02:25 PM
lcjarrett
Honda Civic / Del Sol (1992 - 2000)
3
02-18-2006 11:37 PM
mechanik
Honda Civic / Del Sol (1992 - 2000)
4
06-14-2002 05:41 PM
mechanik
Tech / Misc
3
06-14-2002 05:38 PM


Thread Tools
Search this Thread
Quick Reply: D16Y8 in EG swap, VTEC not working


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: