Go Back  Honda-Tech - Honda Forum Discussion > Honda and Acura Technical Forums > Hybrid / Engine Swaps
Reload this Page >

Continuation of Issues after Swapping D16Z6 into 1997 Civic DX

Hybrid / Engine Swaps Discussions about non-stock engine swaps into Honda cars. This is not a forum for hybrid gas/electric cars.
Sponsored by:
Sponsored by:

Continuation of Issues after Swapping D16Z6 into 1997 Civic DX

 
Old 05-26-2018, 09:49 PM
  #1  
Honda-Tech Member
Thread Starter
 
Join Date: Jul 2017
Posts: 25
Default Continuation of Issues after Swapping D16Z6 into 1997 Civic DX

So i've posted this before but now I have a video showing issues that i'm having. Here is the original post:https://www.reddit.com/r/Honda/comments/8gc4lq/help_needed_been_fighting_issues_with_d16z6_since/?st=jhnlslnx&sh=4cb806a1

So now I have a video actually showing the issues:

So far I have changed plugs (NGK), Wires (denso), have changed rotor, cap looked fine so I didn't replace it. I have cleaned the FITV and IACV. I just ran some Seafoam through the intake manifold to clean it. Injectors have been cleaned and so have the filters. As you can see in my last post, the car is running the stock d16y7 wiring harness which is using an obd2a-obd1 jumper to the p28 ecu. The distributor is wired using a jumper harness adapter as well. Vtec is wired properly although I can't feel it engage as much as I used to, and all grounds appear to be solid (checked for resistance). Fuel filter was replaced when the swap happened. Car has been timed perfectly with a timing light. Last time I checked compression, the readings were all withing 10% of each other although I don't think that this is a compression issue. I am going to check fuel pressure today. Last time I checked, the fuel pressure was perfect. I have seen so many posts about bogging with the z6, I laugh every time I see someone wanting to buy one. I can't imagine everyone has this issue and just lives with it. The first gear stumble is so intermittent that I really have a hard time trusting the car to cross an intersection.

-Note, the CEL in that is visible in the video is for O2 sensor. I had this code a while back so i replaced the O2 sensor and the light went away for a bit. The light still comes on every once in a while. Even after replacing the O2 sensor, the performance of the car did not improve.

Due to this issue, I have found that I need to drive in 2nd or 3rd gear most of the time. I get a lot of sputtering during the low end of 2nd gear. Also, I always need to shift into 1st gear to take turns (i've never driven a car like this). My overdrive gear is basically 4th gear as the car actually slows down on its own in 5th gear with foot to the floor (I have gone from 60mph down to 40 in 5th). I have been scouring the internet for answers ever since the swap (almost a year now). I have come across many dead end threads and it's seeming like such a waste of time and money trying to solve this issue. Hopefully someone can offer some more suggestions for how to fix this. Thanks
Cozmikk is offline  
Old 05-28-2018, 02:38 PM
  #2  
Honda-Tech Member
Thread Starter
 
Join Date: Jul 2017
Posts: 25
Default Re: Continuation of Issues after Swapping D16Z6 into 1997 Civic DX

Bump. There has to be a solution.
Cozmikk is offline  
Old 05-31-2018, 08:34 AM
  #3  
Honda-Tech Member
 
Join Date: Jan 2012
Posts: 137
Default Re: Continuation of Issues after Swapping D16Z6 into 1997 Civic DX

Stock ecu? Did you check tps voltages?
halfakneegrow is offline  
Old 06-03-2018, 11:20 AM
  #4  
Honda-Tech Member
Thread Starter
 
Join Date: Jul 2017
Posts: 25
Default Re: Continuation of Issues after Swapping D16Z6 into 1997 Civic DX

Originally Posted by halfakneegrow View Post
Stock ecu? Did you check tps voltages?
The ECU is the p28 which is meant for the engine. I cleaned the o2 sensor and haven't gotten a code since (because an o2 sensor code is what was giving the CEL in the video). I just readjusted the tps and it is now as perfect as it gets to the .5-4.5V reading it's supposed to have. Map sensor has been replaced and the bogging improved after that so i'm pretty sure that's not the issue. I will be checking fuel pressure next but I won't be surprised if that's spot on as well as it was when I last checked. After that, I don't know what's even left to check.

Last edited by Cozmikk; 06-03-2018 at 11:21 AM. Reason: missing a quote
Cozmikk is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
civicsitek GanGsTa
Honda Civic / Del Sol (1992 - 2000)
1
08-24-2002 05:45 PM
Knightsport
General Discussion and Debate
15
07-31-2002 02:24 PM
solo-x
Road Racing / Autocross & Time Attack
3
07-28-2002 08:36 PM
GS-ARE faster than you
Acura Integra
0
08-31-2001 05:21 PM
accordking
Tech / Misc
1
07-31-2001 09:58 PM


Thread Tools
Search this Thread
Quick Reply: Continuation of Issues after Swapping D16Z6 into 1997 Civic DX


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: