Honda Civic / Del Sol (1992 - 2000) EG/EH/EJ/EK/EM1 Discussion

Motor runs extremely rich at high rpm

 
Old 03-01-2010, 02:46 AM
  #1  
Junior Member
Thread Starter
 
Suzukii's Avatar
 
Join Date: Sep 2005
Location: F1 night race
Posts: 162
Likes: 0
Received 0 Likes on 0 Posts
Default Motor runs extremely rich at high rpm

Hi guys,

I'm running a B20vtec on EG6, OBD1, S300 P30 ECU.

Motors runs ok at low revs, up to 3000rpm, above that and into vtec, the motor runs extremely rich. My LM2 reader jumps from 13:1 to 8:1 at high revs.

In order to tune the fuel down to 13:1 the map has to be reduced to almost 50% of the normal fuel map, which is too little fueling.

I thought the distributor wasnt firing properly at high revs and not burning the fueling and dumping it out. Swapped a new distributor and the problem persisted.

I can only imagine that the problem is with the wiring harness. Its an original OBDI harness but there are some wires might have been tapped by previous owner for gauges etc.

Could there be noise interference or grounding issues causing the distributor to run bad at high rpm or other issues that cause the injectors to run too rich?
Suzukii is offline  
Old 03-01-2010, 05:27 AM
  #2  
I'm not Rick!
 
rick_rabies's Avatar
 
Join Date: Feb 2009
Location: under a prayer shawl
Posts: 6,940
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Motor runs extremely rich at high rpm

sounds like you need to use that fancy s300 and makes some changes in it (tune it)
fyi there was a ground wire test. dont put a ground on the dizzy youl lose power and function.
the best place for ground is the head, tranny, ecu, and block
rick_rabies is offline  
Old 03-01-2010, 07:03 AM
  #3  
Junior Member
Thread Starter
 
Suzukii's Avatar
 
Join Date: Sep 2005
Location: F1 night race
Posts: 162
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Motor runs extremely rich at high rpm

Originally Posted by rick_rabies View Post
sounds like you need to use that fancy s300 and makes some changes in it (tune it)
fyi there was a ground wire test. dont put a ground on the dizzy youl lose power and function.
the best place for ground is the head, tranny, ecu, and block

There is nothing wrong with the S300 map. I'm using a tuned map for the same engine. Something's wrong with the ignition at high rpms. Seems like its dumping the fuel unburnt causing the extremely rich AFR.

Just to give you an example, if your fuel numbers at 5000rpm is at 650 with afr of 13:1, and vtec engages at 5500rpm and the fuel number is 660 it jumps into 8:1. In order to bring the AFR back to 13:1, i need to reduce the fuel number to 300 and there is no power!

Can you explain the ground wire test? I think the harness is badly grounded causing some noise to the distributor.
Suzukii is offline  
Old 03-01-2010, 08:17 AM
  #4  
Honda-Tech Member
 
hondamark35's Avatar
 
Join Date: Feb 2005
Location: Home of the Okra Strut
Posts: 3,712
Likes: 0
Received 1 Like on 1 Post
Default Re: Motor runs extremely rich at high rpm

are you using all "stock" parts on the B20V? do you have cams or any other upgraded internals?
hondamark35 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
chriswboon
Tech / Misc
21
01-30-2010 06:06 PM
jaredvabeach
Honda Civic / Del Sol (1992 - 2000)
4
09-02-2009 12:22 PM
Jwbetley
Honda CRX / EF Civic (1988 - 1991)
3
03-04-2009 01:29 PM
Coltmorris
Honda CRX / EF Civic (1988 - 1991)
12
02-09-2007 09:13 AM
asubennett
All Motor / Naturally Aspirated
6
08-27-2005 10:15 PM


Thread Tools
Search this Thread
Quick Reply: Motor runs extremely rich at high rpm


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: