Honda Civic / Del Sol (1992 - 2000) EG/EH/EJ/EK/EM1 Discussion

Heat and Idle issue

 
Old 08-08-2004, 10:58 AM
  #1  
Thread Starter
 
hondaman2's Avatar
 
Join Date: Aug 2004
Location: Columbus, OH, USA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Heat and Idle issue

This is what i have that is the motor

1995 Civic EX (D16Z)

JRSC (9lbs boost)
JRSC Fuel Pump
JRSC Fuel Pressure regulator
AEM Intake (NEW)
MSD 6 With boost retard
MSD wires
V-AFC
Gude Throttle Body
ACT Clutch w/ Flywheel
99 Civic Headers


This is what i have replaced in the past week.

Radiator
Radiator cap
Timing belt
super charger belt
power steering belt
Honda Metal head gasket
Honda water pump
Cap& rotor
Denso Plugs
Injectors (stock)
Fuel rail (stock)
AEM Intake
Thermostat (170 degrees)
02 Sensor
New oil change
Coolant flush
IACV

With all these things replaced I still have a odd idle speed when at a complete stop about 1500 rpm if i hit the gas real qwick it will idle at 900 rpm. still to high i should be 650-750 rpm.

ISSUE 1
When i get on the freeway and boost it reall qwick it will idle really high when i put it in Nuetral @ 4000 RPM and i have to down shift to get it down from that.
Issue 2
I also have a cooling issue as well.
The issue being it will heat up a past way past 210 Degress then i will have to turn on the heat to disipate it. We did a correct 50/50 mix and let it sit to get air out of the lines. Also hiiked a pressure tester to the coolant system it help like a champ @ 17lbs

Issue 3
Air/Fuel
Replaced the O2 Sensor and my gauge says that i am runnig all the way lean doesnt even read at all. When i do start from the morning at a cold start it will go up but only half way sometimes more but a mile down the road it drops Big time all the way so it doesn not read.

I have tried 3 O2 sensors and all the same senario and i know the gauge is right because my car runs like poo with no fuel. There have been a couple and i do mean a couple of times it went all rich and pulled like a scared puppy

So i am at a losing point and cannot think of anything can someone help ? Thanks in advance.


Any suggestions would GREATLY appreciated



Modified by hondaman2 at 12:08 PM 8/8/2004
hondaman2 is offline  
Old 08-08-2004, 12:29 PM
  #2  
Thread Starter
 
hondaman2's Avatar
 
Join Date: Aug 2004
Location: Columbus, OH, USA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Heat and Idle issue (hondaman2)

anyone have anything ? Please
hondaman2 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bizmackus
Acura Integra
4
02-16-2007 06:34 PM
kmaralit
Honda Accord (1990 - 2002)
3
06-30-2005 09:23 AM
messeduprex
Honda CRX / EF Civic (1988 - 1991)
2
06-24-2004 10:13 AM
Desperado
Forced Induction
5
02-02-2004 04:45 PM
gooberwolf
Honda Accord (1990 - 2002)
4
08-06-2003 01:59 PM


Thread Tools
Search this Thread
Quick Reply: Heat and Idle issue


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: