Honda Civic / Del Sol (1992 - 2000) EG/EH/EJ/EK/EM1 Discussion

B16a2 dies when starting, hunts idle, and sputters randomly

 
Old 06-09-2019, 05:10 PM
  #1  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default B16a2 dies when starting, hunts idle, and sputters randomly

I just bought a 94 hatch with b16a2 swap. It was hunting idle pretty bad when I bought it, so I checked for vacuum leaks and replaced the tps since I have a new one lying around. Before replacing the tps, I was messing with the old one and was able to get the hunting to stop (I did smack my iacv a couple times but idle didn't change when doing so). After I got the hunting idle to settle it started having an issue starting. It turns over and starts but idle drops until it dies and sometimes pressing gas doesn't affect it. I plugged up the new tps and calibrated it but I'm still getting all the same issues. Including sputtering occasionally and not making power during acceleration. It's plugged up to a p30 ecu and I'm not really sure what's going on. On the verge to taking it to a shop but I'm on a tight budget and dont want to just throw parts at it and end up in the same position. Any help is appreciated as I'm new to all of this and still learning.
Anakin541 is offline  
Old 06-09-2019, 05:17 PM
  #2  
Honda-Tech Member
 
tamboo's Avatar
 
Join Date: Jul 2013
Location: sleeping in a 368k 95 gs-r
Posts: 1,690
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

check tps with voltmeter again.
mine just drifted out of spec again since it wasnt torqued down hard enough
and did a lot of the same stuff.
screws and allen bolts wont cut it as it's
too hard to tighten enough.
get the 8mm bolts if you haven't and crank em hard.
also look into ignition switch it might be coated in carbon gunk:

https://www.team-integra.net/forum/1...-cleaning.html
tamboo is offline  
Old 06-09-2019, 05:21 PM
  #3  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

I'll run another volt test on it again and wrench it down a little but I made sure she was snug. I guess I was also wanting to know could it be fuel delivery? It has a new "looking" filter. And pump cover was off when I bought it. And I don't think it was ignition cud I tested all my ignition wires
Anakin541 is offline  
Old 06-09-2019, 05:25 PM
  #4  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 974
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Post the CEL codes.

You likely bought somebody's failed swap attempt.
muellersfan is offline  
Old 06-09-2019, 05:42 PM
  #5  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

I don't have a reader, and cel isn't on at all. Should I get a diagnostic and post an update? Also thinking about cleaning iacv valve and seeing if that does anything.
Anakin541 is offline  
Old 06-09-2019, 06:02 PM
  #6  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Still .48 at tps
Anakin541 is offline  
Old 06-09-2019, 06:08 PM
  #7  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 974
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Originally Posted by Anakin541 View Post
I don't have a reader, and cel isn't on at all. Should I get a diagnostic and post an update? Also thinking about cleaning iacv valve and seeing if that does anything.
Does the CEL work? Has the bulb been removed or disabled? It's a common trick used by unscrupulous sellers to hide problems.

You can't connect an OBD2 code reader to an OBD1 ECU. You instead short the service connector and then watch the CEL blink codes.
muellersfan is offline  
Old 06-09-2019, 06:23 PM
  #8  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

It does work, flashes like usual when turning the key over. But as far as shorting it ill try it and update with codes
Anakin541 is offline  
Old 06-09-2019, 06:27 PM
  #9  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 974
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Originally Posted by Anakin541 View Post
It does work, flashes like usual
Do you mean the CEL turns on for 2 seconds and then turns off and stays off? Or does it turn on while you are driving?

Does the car clock hold time after turning off the car? Are set radio stations retained?

But definitely check for codes stored in the ECU.
muellersfan is offline  
Old 06-09-2019, 07:01 PM
  #10  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Clock is deleted and radio is ripped out. Cel turns on for the normal 2 seconds when starting and stays off, but I know it works because of that. Never seen it flash while driving or messing with stuff
Anakin541 is offline  
Old 06-09-2019, 07:06 PM
  #11  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 974
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Originally Posted by Anakin541 View Post
Clock is deleted and radio is ripped out.
Check whether the 7.5A Back UP fuse under the hood is blown. The ECU memory won't store CEL codes unless this fuse is working and the wire is attached to the ECU.
muellersfan is offline  
Old 06-09-2019, 07:12 PM
  #12  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Will do
Anakin541 is offline  
Old 06-09-2019, 07:35 PM
  #13  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 974
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

You can also unplug a sensor to check whether the CEL turns on and stays on and whether the code is stored after turning the car off for 5 minutes.

If all is fine with the CEL and ECU, check the cam timing. It may be off by a tooth.
muellersfan is offline  
Old 06-09-2019, 07:48 PM
  #14  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Kinda what I was thinking. Would have to take it in to check timing. Will check codes when I get home, clean iacv, but if don't figure it out or it is timing she'll have to go in. I'll keep updating. Thanks again
Anakin541 is offline  
Old 06-09-2019, 07:57 PM
  #15  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Also not sure if this helps but vtec isn't kicking until 6k. Maybe has something to do with timing if it was off? Idk
Anakin541 is offline  
Old 06-09-2019, 07:59 PM
  #16  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 974
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Originally Posted by Anakin541 View Post
Would have to take it in to check timing.
To check the cam timing, remove the valve cover and upper timing belt cover. Turn the crank pulley counterclockwise until the cams at at TDC1. Then check whether the crank pulley is also at TDC1. If it is not or if the cam pulleys are not perfectly aligned, then the cam timing is off.
muellersfan is offline  
Old 06-09-2019, 08:38 PM
  #17  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Okay thanks for the help. I'm gonna run volt tests from tps to ecu, check codes, clean iacv and if If nothing cam timing. Thanks again, it's getting late so I won't have updates until tomorrow
Anakin541 is offline  
Old 06-09-2019, 09:27 PM
  #18  
Honda-Tech Member
Thread Starter
 
Join Date: Jun 2019
Posts: 11
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

So I went and checked for codes and jumped the cel, but when I did it it didn't flash at all, but held solid. I know my 7.5 is good cus i just checked all my fuses. Did i somehow do it wrong? i also smacked my iacv before cold starting it and it actually started up first try. Also seemed to slightly surge idle when I played with headlights but it wasn't conclusive enough to say it defiantly was. Part of me is leaning toward iacv.
Anakin541 is offline  
Old 06-09-2019, 09:43 PM
  #19  
Intelligently Stupid
 
TomCat39's Avatar
 
Join Date: Jan 2013
Posts: 7,907
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

No, solid with the service connector in means no codes and ECU is in service mode. Used for setting ignition timing.
TomCat39 is offline  
Old 06-10-2019, 05:07 AM
  #20  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 974
Default Re: B16a2 dies when starting, hunts idle, and sputters randomly

Originally Posted by Anakin541 View Post
I know my 7.5 is good cus i just checked all my fuses. Did i somehow do it wrong?
The fuse could good but power does not rach the ECU. Unplug the IAT to see if you get a code that remains stored after turning the key off for 5 minutes. If so, all is good there.
muellersfan is offline  
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: