Honda Civic / Del Sol (1992 - 2000) EG/EH/EJ/EK/EM1 Discussion

'96 LX sedan B18b no crank

 
Old 05-07-2019, 05:05 PM
  #1  
Honda-Tech Member
Thread Starter
 
norco123's Avatar
 
Join Date: Oct 2008
Location: Oshawa, ON, Canada
Posts: 10
Default '96 LX sedan B18b no crank

Hi guys I have a '96 LX sedan that is my track car. It has a '97 B18B that ran very well last year, stored over winter (Canada) so I did a few small mods during the off season and now I'm left with a no crank no start scenario. Basically over the winter all that was changed on the car was a Walbro 255 pump, I had the intake manifold off to put in extended studs, I added a catch can and re-did the fuel lines in braided -6an. I ran it last October on track and it ran very well all day and I had a ton of fun in the car since it was the first time driving it with the new half cage and a host of mods...It's on a phearable OBD1 chipped ecu and still has the stock '96 LX harness albeit modified in a few spots to accommodate the B18b swap.

I was hoping someone could point me in the right direction for some Civic related no crank no start scenarios. So far I've power probed my grounds and the only one suspect is the thermostat ground it has not given me a good ground reading thus far. The battery is good I have it on a tender any time the car's not in use and it's holding 12.6V off the tender for over a week now..I initially thought the issue could be main relay I checked mine and the solder joints are A ok, I got a replacement just to try and it made no difference to the no crank. I then went to the ignition switch got a known good replacement, no change in the no crank. The oddest part is that my ECU and fuel pump DO NOT power on except for when they feel like it. Sometimes I key on and I'm able to get the CEL to do it's flash on and off and the pump will prime giving me over 35psi fuel pressure at the rail and holds there steady...The ECU and pump only work on occasion and even when they do the car doesn't even attempt to crank no noises whatsoever just a dead key on situation. What normally happens when I key on is no CEL no pump prime and just the Ebrake and SRS lights illuminated, all others are very dim. I'm going to sand all the grounds down and see if that makes a difference but so far I've been unable to change the no crank. Any help is appreciated thanks!
norco123 is offline  
Old 05-07-2019, 05:36 PM
  #2  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 975
Default Re: '96 LX sedan B18b no crank

The battery may be kaput, despite the 12.6V.
muellersfan is offline  
Old 05-07-2019, 05:50 PM
  #3  
Honda-Tech Member
Thread Starter
 
norco123's Avatar
 
Join Date: Oct 2008
Location: Oshawa, ON, Canada
Posts: 10
Default Re: '96 LX sedan B18b no crank

Yeah I'm going to start tomorrow by bringing home my battery tester and a spare battery see if there's any change. Will clean all the grounds tomorrow as well. Hopefully it is something dumb but simple!
norco123 is offline  
Old 05-08-2019, 06:30 PM
  #4  
Honda-Tech Member
Thread Starter
 
norco123's Avatar
 
Join Date: Oct 2008
Location: Oshawa, ON, Canada
Posts: 10
Default Re: '96 LX sedan B18b no crank

Battery tested fine, cleaned my grounds it was the thermostat ground. Runs like a champppp
norco123 is offline  
Old 05-08-2019, 06:36 PM
  #5  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 975
Default Re: '96 LX sedan B18b no crank

FYI

The thermostat ground has nothing to do with the starter cranking.
muellersfan is offline  
Old 05-09-2019, 04:16 PM
  #6  
Honda-Tech Member
Thread Starter
 
norco123's Avatar
 
Join Date: Oct 2008
Location: Oshawa, ON, Canada
Posts: 10
Default Re: '96 LX sedan B18b no crank

It does if the computer won't power up to distribute any power to anything involved in cranking lol. It did not crank at all. Cleaned and now it cranks starts runs fine. Thanks for the info, I know what you mean starter circuit does not deal specifically with that ground.
norco123 is offline  
Old 05-11-2019, 07:56 PM
  #7  
Honda-Tech Member
 
muellersfan's Avatar
 
Join Date: Apr 2018
Posts: 975
Default Re: '96 LX sedan B18b no crank

Originally Posted by norco123 View Post
Thanks for the info, I know what you mean starter circuit does not deal specifically with that ground.
Correct.
muellersfan is offline  
 


Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: