Honda Civic / Del Sol (1992 - 2000) EG/EH/EJ/EK/EM1 Discussion

93 Honda Civic Si losing power?

 
Old 06-26-2012, 04:27 PM
  #1  
Honda-Tech Member
Thread Starter
 
92cb7sk8er's Avatar
 
Join Date: Sep 2010
Location: lima ohio
Posts: 166
Likes: 0
Received 0 Likes on 0 Posts
Icon2 93 Honda Civic Si losing power?

Heyy guys about 3 days ago I was driving my 93 civic si when it started to just sputter and it seemed to lose power. When this happens if I give it more gas it seems like the car pretty much start to slow and the RPMs drop until I either shift or just let up off the gas. I have no idea with this could be the CEL is not on and I havent really done anything to it for awhile. It has the D16Z6 motor. Any help would be great guys thanks,
Cody
92cb7sk8er is offline  
Old 06-26-2012, 04:29 PM
  #2  
EK9
iTrader: (7)
 
Dc4LsTeG's Avatar
 
Join Date: Feb 2009
Location: so cal,ca
Posts: 5,270
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

When's the last time you did a tune up?
Dc4LsTeG is offline  
Old 06-26-2012, 05:02 PM
  #3  
Honda-Tech Member
Thread Starter
 
92cb7sk8er's Avatar
 
Join Date: Sep 2010
Location: lima ohio
Posts: 166
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Originally Posted by Dc4LsTeG View Post
When's the last time you did a tune up?
I changed the oil, filter and added fuel cleaner on 5/22 but as for the wires plugs the cap and belts its been with in the last year but I can't remember the date for sure
92cb7sk8er is offline  
Old 06-30-2012, 06:29 PM
  #4  
Honda-Tech Member
Thread Starter
 
92cb7sk8er's Avatar
 
Join Date: Sep 2010
Location: lima ohio
Posts: 166
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Alright so far I have changed the plugs but it still did it. But now I am thinking its in the fuel system I just changed the fuel filter but wont know if it fixed the problem until I drive it so I will let you guys know but as for the old filter it had alot of crap in it so I am hoping thats what it was. But like I said I will let you guys know and go from there.
92cb7sk8er is offline  
Old 06-30-2012, 06:35 PM
  #5  
Honda-Tech Member
 
beecee18's Avatar
 
Join Date: Mar 2011
Location: Southern California
Posts: 1,162
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Originally Posted by 92cb7sk8er View Post
added fuel cleaner on 5/22
beecee18 is offline  
Old 06-30-2012, 09:53 PM
  #6  
Honda-Tech Member
 
Join Date: Mar 2011
Posts: 43
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

clogged injector?
JUICE66 is offline  
Old 07-02-2012, 11:55 AM
  #7  
Honda-Tech Member
 
Join Date: Jul 2009
Posts: 649
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

The fuel cleaner may have broke loose some sediment in the tank that may have clogged the fuel pump sediment screen as well as the fuel filter. I think the fuel pump is located inside your gas tank and the sediment screen hangs off the pump. It's not that hard to change. On my 93 del sol the fuel pump access is on top of the gas tank.
delsolintegra is offline  
Old 07-02-2012, 12:43 PM
  #8  
WSA
Honda-Tech Member
 
WSA's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 43
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

as wierd as it sounds. I think it is the coolant temperature sensor. Had this problem with one of my civics. It would bog out at about 2k rpms. replace the coolant temp sensor ( not the sensor for the gauge but the larger one near upper radiator house. Otherwise it could be 02 or cracked manifold near the 02? Let us know what you find out.
WSA is offline  
Old 07-02-2012, 05:16 PM
  #9  
Honda-Tech Member
Thread Starter
 
92cb7sk8er's Avatar
 
Join Date: Sep 2010
Location: lima ohio
Posts: 166
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Alright well my guess is that it was the fuel filter because since I have changed it its been running good as new! Its about time its a cheap easy fix lol but thanks for all the info guys!
92cb7sk8er is offline  
Old 07-02-2012, 05:18 PM
  #10  
Honda-Tech Member
Thread Starter
 
92cb7sk8er's Avatar
 
Join Date: Sep 2010
Location: lima ohio
Posts: 166
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Originally Posted by WSA View Post
as wierd as it sounds. I think it is the coolant temperature sensor. Had this problem with one of my civics. It would bog out at about 2k rpms. replace the coolant temp sensor ( not the sensor for the gauge but the larger one near upper radiator house. Otherwise it could be 02 or cracked manifold near the 02? Let us know what you find out.
I had some guy telling me about that so it might happen more then people know lol but thats what I was going to try next but i think the new fuel filter fixed it I havent driven the car but my wife has and she says its running fine
92cb7sk8er is offline  
Old 07-03-2012, 12:03 PM
  #11  
WSA
Honda-Tech Member
 
WSA's Avatar
 
Join Date: May 2012
Location: Minnesota
Posts: 43
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Glad you got it fixed. Yea its strange a coolant temperature sensor is the last thing i would think of if my car is bogging. Fuel filter was a nice cheap fix, how relieving.
WSA is offline  
Old 07-05-2012, 07:38 PM
  #12  
Honda-Tech Member
Thread Starter
 
92cb7sk8er's Avatar
 
Join Date: Sep 2010
Location: lima ohio
Posts: 166
Likes: 0
Received 0 Likes on 0 Posts
Icon3 Re: 93 Honda Civic Si losing power?

Originally Posted by WSA View Post
Glad you got it fixed. Yea its strange a coolant temperature sensor is the last thing i would think of if my car is bogging. Fuel filter was a nice cheap fix, how relieving.
Well I guess I lied it only seem to have fixed it for about 2 days and then it started doing it again. O.o Sorry guys I thought it was fixed but tonight I did go ahead and change the coolent sensor, I have a few extra ones. lol But if this doesn't fix it I will let you guys know what I will try next until I get this fixed lol But again sorry for telling you it was fixed I really thought it was lol but we will see how far this coolent sensor will get me. Thanks again!
92cb7sk8er is offline  
Old 07-06-2012, 05:22 AM
  #13  
Honda-Tech Member
 
Join Date: Jul 2009
Posts: 649
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Now it really sounds like the fuel pump sediment screen varnished over from the fuel line cleaner additive.
delsolintegra is offline  
Old 07-07-2012, 11:02 AM
  #14  
Honda-Tech Member
 
beecee18's Avatar
 
Join Date: Mar 2011
Location: Southern California
Posts: 1,162
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 93 Honda Civic Si losing power?

Originally Posted by delsolintegra View Post
Now it really sounds like the fuel pump sediment screen varnished over from the fuel line cleaner additive.
beecee18 is offline  
Old 07-18-2012, 12:03 PM
  #15  
Honda-Tech Member
Thread Starter
 
92cb7sk8er's Avatar
 
Join Date: Sep 2010
Location: lima ohio
Posts: 166
Likes: 0
Received 0 Likes on 0 Posts
Icon6 Re: 93 Honda Civic Si losing power?

Alright guys its been like a week since I have worked on the Civic and I chaged the coolent temp. sensor, the one with the little pong like plug and it has been running just fine. So the answer to the problem here would be the "Coolent temp sensor was bad" which makes no since to me but it seems to be fixed so...

Last edited by 92cb7sk8er; 07-19-2012 at 07:22 AM.
92cb7sk8er is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
92cb7sk8er
Honda Civic / Del Sol (1992 - 2000)
15
01-24-2014 06:12 AM
cennouu
Honda Civic / Del Sol (1992 - 2000)
5
11-19-2010 07:43 PM
jawsiiv
Honda Civic / Del Sol (1992 - 2000)
6
08-16-2008 12:26 PM
pinoyboy204
Honda Civic / Del Sol (1992 - 2000)
9
03-07-2007 06:32 AM
EPrepCivic
Tech / Misc
3
03-11-2003 03:51 PM


Thread Tools
Search this Thread
Quick Reply: 93 Honda Civic Si losing power?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: