Honda Accord & Crosstour (2003 - 2012) 2003 - 2012 Honda Accord and Inspire

P0470 comes and goes

 
Old 05-02-2019, 03:37 PM
  #1  
Trial User
Thread Starter
 
Join Date: May 2019
Posts: 2
Default P0470 comes and goes

2007 Honda Accord SE 200,000 miles
Every once in a while the check engine light comes on. I was able to figure out that the code is P0470. Rather than pay a shop for further diagnosis I simply ordered a new $13 MAP sensor associated with that code. The part number is REPH315202.
After I installed the sensor and started the car it had an extremely rough idle and almost stalled a few times. I tried to rev the engine to 3k RPM but it would only go to 2k RPM and then stall. I swapped the old sensor back in and everything is fine. Is the new sensor bad? Do I need to do some kind of relearn?
Rtk513 is offline  
Old 05-02-2019, 04:43 PM
  #2  
Global Moderator
 
tech8's Avatar
 
Join Date: Jul 2004
Posts: 3,611
Default Re: P0470 comes and goes

P0470 is not a listed Honda OBD-II trouble code for that generation Accord.
tech8 is offline  
Old 05-03-2019, 10:56 AM
  #3  
Trial User
Thread Starter
 
Join Date: May 2019
Posts: 2
Default Re: P0470 comes and goes

Originally Posted by tech8 View Post
P0470 is not a listed Honda OBD-II trouble code for that generation Accord.
IDK but that is the code we picked up and I can google it with plenty of examples
Rtk513 is offline  
Old 05-03-2019, 03:43 PM
  #4  
Honda-Tech Member
 
DCFIVER's Avatar
 
Join Date: Mar 2004
Location: failing a car near you.....
Posts: 4,307
Default Re: P0470 comes and goes

Originally Posted by Rtk513 View Post
2007 Honda Accord SE 200,000 miles
Every once in a while the check engine light comes on. I was able to figure out that the code is P0470. Rather than pay a shop for further diagnosis I simply ordered a new $13 MAP sensor associated with that code. The part number is REPH315202.
After I installed the sensor and started the car it had an extremely rough idle and almost stalled a few times. I tried to rev the engine to 3k RPM but it would only go to 2k RPM and then stall. I swapped the old sensor back in and everything is fine. Is the new sensor bad? Do I need to do some kind of relearn?
Lol, guess you better pay a shop to diagnose it after all. or continue to throw money at the problem.

You're on the wrong track so far, there is no such code as P0470 for that year Accord.....
DCFIVER is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: