Honda Accord & Crosstour (2003 - 2012) 2003 - 2012 Honda Accord and Inspire

2006 Accord ABS light, alternator light, limp modes and other codes

 
Old 01-25-2019, 02:51 PM
  #1  
Honda-Tech Member
Thread Starter
 
Join Date: Jan 2019
Posts: 2
Default 2006 Accord ABS light, alternator light, limp modes and other codes

Hi, I have a 2006 Accord 2.4L with about 275k miles last week I drove about 25 miles, got out and left it idling for about 5 minutes. Got back in and the ABS light was on, drove off and it went in to limp mode. Turned around and came back and the alternator light came on. Put a cheap code reader on and it was throwing a bunch of codes, most of which were for camshaft position sensor and one MAF sensor code. I know I shouldn't replace parts strictly based on codes, but I replaced the back (exhaust?) CPS. After that, the car started up again (but it didn't want to at first). Still was in limp mode, so I replaced the other CPS, then it would not start at all. Got a better code reader and it was only showing the MAF sensor low voltage code, took it out and cleaned it off, but the car still won't start. I put the original front CPS back in and still wouldn't start. Try to clear the MAF sensor code and it won't go away. The car turns over, but it won't fire. Once in a while, it sounds like it wants to go, but won't. Not sure about my next step, any help or thoughts would be appreciated.

Thanks,
markerickson200 is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: