Honda Accord & Crosstour (2003 - 2012) 2003 - 2012 Honda Accord and Inspire

09 Accord won’t start after motor swap

 
Old 02-08-2019, 08:36 PM
  #1  
Trial User
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Default 09 Accord won’t start after motor swap

I replaced the 2.4L in my 09 Accord with another 2.4L and now it won’t start. Timing is dead on, has spark fuel and air. Engine code for high voltage in temp sensor and for rocker arm oil pressure switch. It also now has 4 transmission codes. Any thoughts?

Thanks
kevin916sfs is offline  
Old 02-09-2019, 07:38 AM
  #2  
Global Moderator
 
tech8's Avatar
 
Join Date: Jul 2004
Posts: 3,615
Default Re: 09 Accord won’t start after motor swap

  • Check ground G101.
  • Check Under-hood Fuse No. 17 (15A).
  • Check connectors to the ECM/PCM.
  • Check the battery terminal connection. Also check the battery negative connection on the chassis.
tech8 is offline  
Old 02-10-2019, 02:32 PM
  #3  
Trial User
Thread Starter
 
Join Date: Feb 2019
Posts: 2
Default Re: 09 Accord won’t start after motor swap

Thanks, one of the connections on the ECU was loose. I popped it back on and now the car starts, idles for about three seconds and cuts off. Fuse and grounds were both good
kevin916sfs is offline  
Old 02-10-2019, 03:54 PM
  #4  
Global Moderator
 
tech8's Avatar
 
Join Date: Jul 2004
Posts: 3,615
Default Re: 09 Accord won’t start after motor swap

Are there any trouble codes still existing?
tech8 is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: