Honda Accord & Crosstour (2003 - 2012) 2003 - 2012 Honda Accord and Inspire

04 accord 2.4 problems

 
Old 04-21-2019, 11:31 AM
  #1  
Trial User
Thread Starter
 
Join Date: Apr 2019
Posts: 1
Default 04 accord 2.4 problems

Hey. Figured I'd come here for some help.

Got a 2004 accord 2.4 automatic. 156k on the clock. Buddy brought it to me. He replaced the throttle body and the air I let hose. He said it was not shifting at all. And would bot let him go over 2900rpm. Or 30 mph.

I did the old wire trick to pull codes. Got code 7 from the engine light blinking. Also got code 29 from the transmission drive light blinking.

Went and got boght a $20 scan tool. And it only gives my P0760 shift solenoid C malfunction.

I removed, tested, seems to be just fine. Even went as far as to replace it with one from a wrecked car. Still no change

I've pulled .5v from every solenoid plug. Have continuity from each plug to the ECM.

Tps sensor shows .45 bolts up to 4.5 volts. Slightly less than the .5v- 5v that's it says. Figured it was close enough. Car runs fine. Responds to throttle fine. Idles fine. Hest cycles fine.

I tried to erase the codes with the scanner. It tells me it erased them. But lights never turn off.

I picked up another ecm to try. Plug it in, no engine lights. All looks good but wont statt due to the key immobilizer.

Not sure what else to try or do.
Jer4251 is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: