Maxwellmercer-Quest for 500whp inside

 
Old 05-11-2019, 12:32 PM
  #26  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by maxwellmercer View Post
So, I'll chalk this up as a learned lesson here. READ.

I inadvertently read the color code for the MVR wastegate, not the MVS as I should've. The color combination I had calculated to about 14.5 psi. Maybe I dont have an issue at all! Except an operator issue. Crying face!!!
Woops! I figured that'd be the first place to start. SF miniram is a good unit and the wg placement is good also. Looks like your issue is simple.

How was it looking on the dyno? How was the turbo performance? With near full boost at 4400 rpm, this is interesting news to me as well.

Originally Posted by TheShodan View Post
there are two ways to order it. you can get one with a specific spring in it, ( like a .9bar like I did) or the general MV-S, which comes with the additional springs. the part numbers are differently subtle
I ordered the .9bar unit. Still thought it was multiple springs though.
Txdragon is online now  
Old 05-11-2019, 12:58 PM
  #27  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside




We really didnt get into it too much, we did some heavy decel to seat the rings for a little bit to start. We then started with some baseline pulls and immediately realized we had an issue. Unfortunately I brought everything in the world except for the wastegate box with all the springs. So in favor of both of our times, we decided to pull it off and try for another day. The setup is stupid efficient and responsive, it's going to be SO much fun when it's all dialed in.
maxwellmercer is offline  
Old 05-11-2019, 03:03 PM
  #28  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by maxwellmercer View Post



We really didnt get into it too much, we did some heavy decel to seat the rings for a little bit to start. We then started with some baseline pulls and immediately realized we had an issue. Unfortunately I brought everything in the world except for the wastegate box with all the springs. So in favor of both of our times, we decided to pull it off and try for another day. The setup is stupid efficient and responsive, it's going to be SO much fun when it's all dialed in.
This is good data for me too. Lol! Since our turbos are really close in specs; think I've got you on the compressor side by .5 to 1mm, but turbine specs are identical. Kinda sucks you had to shut it down and reschedule though.
Txdragon is online now  
Old 05-13-2019, 05:26 AM
  #29  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside

Most of the time, these silly issues will "solve themselves" by simply stepping back and evaluating the situation at another time. No sense in rushing and getting frustrated!
maxwellmercer is offline  
Old 05-13-2019, 08:47 PM
  #30  
Honda-Tech Member
 
BoostHatchFreak's Avatar
 
Join Date: May 2019
Location: Nor cal
Posts: 54
Default Re: Maxwellmercer-Quest for 500whp inside

super clean teg. ive use aem all the time not one problem with there products. great looking build hope your next dyno day goes smother.
BoostHatchFreak is offline  
Old 05-15-2019, 04:17 AM
  #31  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by BoostHatchFreak View Post
super clean teg. ive use aem all the time not one problem with there products. great looking build hope your next dyno day goes smother.

Thanks! I really hope so too!!


I drove the car for a few tonight to try one of 2 tests after I changed the wastegate spring. I made sure my mac valve was off and the pressure didn't exceed 9 psi (I believe it equates to be a 8.7psi spring) everything is good! Tonight I am going to put regulated air to the wastegate and make sure its opening at the 8-9psi realm. All should be good but, I would rather be safe and "bench" test it. Other than that everything seems great, so hopefully I'll be back to the dyno very shortly!
maxwellmercer is offline  
Old 05-15-2019, 04:30 AM
  #32  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by maxwellmercer View Post


I drove the car for a few tonight to try one of 2 tests after I changed the wastegate spring. I made sure my mac valve was off and the pressure didn't exceed 9 psi (I believe it equates to be a 8.7psi spring) everything is good! Tonight I am going to put regulated air to the wastegate and make sure its opening at the 8-9psi realm. All should be good but, I would rather be safe and "bench" test it. Other than that everything seems great, so hopefully I'll be back to the dyno very shortly!
This is good news!
Txdragon is online now  
Old 05-15-2019, 06:15 AM
  #33  
Honda-Tech Member
 
BoostHatchFreak's Avatar
 
Join Date: May 2019
Location: Nor cal
Posts: 54
Default Re: Maxwellmercer-Quest for 500whp inside

some time you have to bench test. you can use the bench test to also see where the gate starts to come off seat and by what psi its all the way open. you can use this to change your boost curve and how boost hits. that with your BBG options will get you any type of curve you want.
BoostHatchFreak is offline  
Old 06-01-2019, 06:27 AM
  #34  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside






Not too much going on just track prepping, waiting to get back on the dyno and cutting holes in my car!
maxwellmercer is offline  
Old 06-01-2019, 06:29 AM
  #35  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Ok, spill it.. Give the story on the hood vent..
Txdragon is online now  
Old 06-01-2019, 07:41 PM
  #36  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside

Essentially just a precaution, because I'm paranoid and over build, to keep temps down on track. Not a huge fan of how it looks but it will function great!
maxwellmercer is offline  
Old 06-02-2019, 10:16 AM
  #37  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by maxwellmercer View Post
Essentially just a precaution, because I'm paranoid and over build, to keep temps down on track. Not a huge fan of how it looks but it will function great!
Where did you get it?
Txdragon is online now  
Old 06-03-2019, 04:25 AM
  #38  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside

It's a company called RPG, it seems like they're mainly Subaru based but have a few other odds and ends as well as "universal" fit parts.
maxwellmercer is offline  
Old 06-06-2019, 07:25 PM
  #39  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside





Well guys, I think it's safe to say I hit my goal! 490whp/330tq @19psi The car feels like an absolute monster and I'm so happy to have it finally tuned.
maxwellmercer is offline  
Old 06-06-2019, 07:30 PM
  #40  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Very nice!! Congrats!
Txdragon is online now  
Old 06-07-2019, 02:42 AM
  #41  
DaX
Honda-Tech Member
iTrader: (1)
 
DaX's Avatar
 
Join Date: Jul 2003
Posts: 4,626
Default Re: Maxwellmercer-Quest for 500whp inside

Congrats!
DaX is offline  
Old 06-07-2019, 03:45 AM
  #42  
Honda-Tech Member
 
turboLScrx's Avatar
 
Join Date: Mar 2001
Location: Bowling Green, ky, USA
Posts: 744
Default Re: Maxwellmercer-Quest for 500whp inside

Congrats!
turboLScrx is offline  
Old 06-07-2019, 08:13 AM
  #43  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by maxwellmercer View Post

Well guys, I think it's safe to say I hit my goal! 490whp/330tq @19psi The car feels like an absolute monster and I'm so happy to have it finally tuned.
I'm betting I'll be around the same psi when my time comes. So far, I've gotten to 18 and the pull feels like being on the gravitron. Lol! Looking at the compressor map, looks about on par with that PR and power level too..
Txdragon is online now  
Old 06-07-2019, 08:44 AM
  #44  
Honda-Tech Member
 
turboLScrx's Avatar
 
Join Date: Mar 2001
Location: Bowling Green, ky, USA
Posts: 744
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by Txdragon View Post
I'm betting I'll be around the same psi when my time comes. So far, I've gotten to 18 and the pull feels like being on the gravitron. Lol! Looking at the compressor map, looks about on par with that PR and power level too..
Soon as I get mine back together, I’m going to try to ge back on the dyno myself, I need some reference numbers , I need to know how much power I’m making at each boost level. I really just want to keep the power right below break my **** level. Lol. I’m guessing that I have to be 550whp range
turboLScrx is offline  
Old 06-07-2019, 09:18 AM
  #45  
DaX
Honda-Tech Member
iTrader: (1)
 
DaX's Avatar
 
Join Date: Jul 2003
Posts: 4,626
Default Re: Maxwellmercer-Quest for 500whp inside

A few questions - did you tune on E85 like you planned? You mentioned in the first post about doing a high boost and low boost toggle switch - is that still the plan?
DaX is offline  
Old 06-07-2019, 10:44 AM
  #46  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside

Thanks guys!

DaX- Yes, the car is on e85. I've actually only ever run E85 in this car even all motor. Unfortunately I'm having creep issues, so we were not able to do a high/low switch like I had anticipated. That is still the plan for the future though!
maxwellmercer is offline  
Old 06-10-2019, 05:41 AM
  #47  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside

So, we were having creep issues on the dyno. I have what Tial says is a 8.7 psi spring installed. At this point the mac valve is turned completely OFF. It doesn't creep to the moon immediately but slowly ramps itself up through the powerband.

Do you guys think the 38mm is too small for my application? Is the .63 exhaust housing not moving enough out for the wastegate to keep up?

I also noticed that the speedfactory manifold doesn't have the wastegate "runner" tear-dropped going into the merge collector.

My tuner and I (Mikey at Mspec Tuning) were thinking the combination of the manifold design and wastegate size is causing my issue.

Forgive me for this somewhat n00b post but I don't want to modify my manifold, throw a bigger gate on and just expect it to fix the issues by guessing.
maxwellmercer is offline  
Old 06-10-2019, 07:25 AM
  #48  
Honda-Tech Member
 
Txdragon's Avatar
 
Join Date: Mar 2016
Posts: 2,047
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by maxwellmercer View Post
So, we were having creep issues on the dyno. I have what Tial says is a 8.7 psi spring installed. At this point the mac valve is turned completely OFF. It doesn't creep to the moon immediately but slowly ramps itself up through the powerband.

Do you guys think the 38mm is too small for my application? Is the .63 exhaust housing not moving enough out for the wastegate to keep up?

I also noticed that the speedfactory manifold doesn't have the wastegate "runner" tear-dropped going into the merge collector.

My tuner and I (Mikey at Mspec Tuning) were thinking the combination of the manifold design and wastegate size is causing my issue.

Forgive me for this somewhat n00b post but I don't want to modify my manifold, throw a bigger gate on and just expect it to fix the issues by guessing.
Sometimes, brother, an educated guess is all we have.
If it's slowly and steadily creeping, I'd say it's gonna be a gate/manifold issue, especially by the symptoms you describe. If it's something like, instant spike and ending at boost cut, your gate isn't opening at all.. That doesn't sound like your case so.. Anywho.. Methinks a larger gate would help mitigate a poorly designed manifold.
Txdragon is online now  
Old 06-10-2019, 11:25 AM
  #49  
Moderator
iTrader: (12)
 
TheShodan's Avatar
 
Join Date: Jan 2002
Location: City of Wind, IL, USA
Posts: 23,310
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by Txdragon View Post
Sometimes, brother, an educated guess is all we have.
If it's slowly and steadily creeping, I'd say it's gonna be a gate/manifold issue, especially by the symptoms you describe. If it's something like, instant spike and ending at boost cut, your gate isn't opening at all.. That doesn't sound like your case so.. Anywho.. Methinks a larger gate would help mitigate a poorly designed manifold.
I disagree. If that compressor cover is being used as the vacuum reference point for the side part of the wastegate, its your reference point that's causing the boost control issue. Relocate that vacuum line to the intake manifold and plug the one up at the compressor inlet. A lot of creep issue occur because of that connection , despite what the interwebs has you believe. Try that first. then look to ignition timing and see if it's too far retarded before target boost pressure.

But I've had that exhaust manifold style/type and wastegate combination work perfectly on countless setups. Ain't nothing wrong with it.
TheShodan is offline  
Old 06-10-2019, 11:44 AM
  #50  
Honda-Tech Member
Thread Starter
 
maxwellmercer's Avatar
 
Join Date: Sep 2008
Location: LoadedForBear,IL
Posts: 2,086
Default Re: Maxwellmercer-Quest for 500whp inside

Originally Posted by TheShodan View Post
I disagree. If that compressor cover is being used as the vacuum reference point for the side part of the wastegate, its your reference point that's causing the boost control issue. Relocate that vacuum line to the intake manifold and plug the one up at the compressor inlet. A lot of creep issue occur because of that connection , despite what the interwebs has you believe. Try that first. then look to ignition timing and see if it's too far retarded before target boost pressure.

But I've had that exhaust manifold style/type and wastegate combination work perfectly on countless setups. Ain't nothing wrong with it.

This is very reassuring! You hit the nail on the head, my source IS the compressor housing. Funny because I just read a post on here AND commented on it saying I needed to switch mine to the intake manifold. Welp, I forgot.

It would be super awesome if this simple fix solved my issue! I'll try it and report back. Thank you!!
maxwellmercer is offline  

Thread Tools
Search this Thread

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: