Engine Management and Tuning Crome, NepTune, Hondata, AEM, MOTEC

eManage Ultimate gurus? Fuel cut?

 
Old 02-06-2018, 05:50 PM
  #1  
Honda-Tech Member
Thread Starter
 
gstrudler's Avatar
 
Join Date: Oct 2007
Location: Oregon City, OR, USA
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
Default eManage Ultimate gurus? Fuel cut?

Any eMange Ultimate gurus out there know if something would cause it to go into fuel cut, like loss of a sensor? I'm having an issue with random freeway stalling and trying to figure out if the EMU is causing it. No CEL on the main ECU, but wondering if something is just off enough that the EMU doesn't like it and kills the motor (instead of going into a limp mode like the stock ECU would). GReddy/Trust doesn't want emails from end-users anymore, so hoping one of you tuner/dealers might be out there and can reach out...
gstrudler is offline  
Old 02-07-2018, 02:11 PM
  #2  
Moderator
iTrader: (12)
 
TheShodan's Avatar
 
Join Date: Jan 2002
Location: City of Wind, IL, USA
Posts: 23,423
Likes: 0
Received 5 Likes on 5 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

I doubt that's E manage, ultimate. It only supplements the ECU. what you have sounds like possibly a bad fuel pump or signal to the pump.
TheShodan is offline  
Old 02-16-2018, 04:44 AM
  #3  
Honda-Tech Member
 
motoxxxman's Avatar
 
Join Date: Mar 2005
Location: CT, US
Posts: 2,365
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

a full description of the car's setup may help a bit.
Also, is it a plug and play harness for the EMU? Or was it manually wired in?
motoxxxman is offline  
Old 02-28-2018, 06:43 PM
  #4  
Honda-Tech Member
Thread Starter
 
gstrudler's Avatar
 
Join Date: Oct 2007
Location: Oregon City, OR, USA
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

1997 Prelude SH:
-Bored & stroked
-Stock cams
-M&W Pro 14 CDI with M&W coils (distributor-less setup, done approx 2 months ago)
-370cc injectors
-Deatschwerks DW200 fuel pump (<1 year old)
-AEM fuel rail and regulator (also <1 year old)
-ATI crank damper
-eManage Ultimate
-vented VC
-Maxbore TB
-Injen SR
-Hytech header & exhaust

eManage was manually wired in, but has been running flawlessly for 4 years. Only recent change related to it is I finally got the sequential ignition working probably two months ago (don't get me started on how dumb GReddy is). The car otherwise is now running great, the only issue is during freeway cruising (only) it will randomly stall. I can cruise at 45-50mph on highways around here and not have problems, but cruising at 55-65mph for a few miles will do it. I can drive faster than that without problem (I can go WOT at 70mph and it picks up just fine), so I don't think it's a fuel supply issue or similar.

Unknown if it's related, but the problem started happening after I did a cooling system flush, which meant idling the car in my garage for 45 minutes. I also am 99% sure that the ignition is still operating and getting a signal from the EMU as the CDI drives my tach and it stays active when the car dies, so I'm almost certain it's a fuel cut.

Replaced since the problem started:
-ignition switch
-main relay
-cat and primary o2 (threw P0420 code; old cat looked not great)
-IACV (old was bad)
-TPS

I'm beginning to wonder if my fuel pump is the problem, and the extra draw at freeway speeds is just enough to kill it for some reason...
Any sensor problems like crank or cam sensors I would expect to show up intermittently at any time, not just on the freeway, but I'm not sure about much at this point.

Last edited by gstrudler; 02-28-2018 at 08:06 PM.
gstrudler is offline  
Old 02-28-2018, 08:04 PM
  #5  
Honda-Tech Member
Thread Starter
 
gstrudler's Avatar
 
Join Date: Oct 2007
Location: Oregon City, OR, USA
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

And for clarification for those not familiar with eManage Ultimate, it is driving the fuel injectors and the CDI directly. ECU injector outputs -> eManage -> injectors. ECU ignition output -> eManage -> Bosch 4-channel ignitor -> CDI -> coils -> plugs.
gstrudler is offline  
Old 03-01-2018, 08:35 PM
  #6  
Honda-Tech Member
 
motoxxxman's Avatar
 
Join Date: Mar 2005
Location: CT, US
Posts: 2,365
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

That doesn't sound like a fuel cut issue at all. And it definitely doesn't sound like a pump issue. Pump current directly relates to the fuel pressure. Higher throttle = higher pressure, so if it cuts out when cruising but not at wot, then it's definitely not the pump.

My guess is either the wiring has developed a break somewhere that only becomes apparent at a specific vibration frequency [correlating with a specific rpm range], or your ignition system is at fault. I don't know what settings you have set up in the emanage, or how you have the M&W set up, but it's totally possible your coil dwell time is not correct, and/or the coils are overheating in that specific rpm range and shutting down until they cool back off.

I'd look more into what to use for dwell times with that setup, and what safety features are built into the M&W system.
And just to eliminate it as a possibility, do some logging and make it cut out. Then review the logs and look to see if any signals are dropping out or going intermittent during the time it cuts out.
motoxxxman is offline  
Old 03-25-2018, 07:53 PM
  #7  
Honda-Tech Member
Thread Starter
 
gstrudler's Avatar
 
Join Date: Oct 2007
Location: Oregon City, OR, USA
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

I finally got it back out again (got a new car, so this has been on the back-burner a little bit) with a fuel pressure gauge extended to where I could see it and datalogging both OBD2 and the eManage to see what I could figure out. As luck would have it I've been having occasional issues with the eManage disconnecting from the eManage software (after a recent update to VMWare), but I didn't realize it until afterwards that I didn't get a good datalog when it cut out.

I was able to verify that fuel pressure is holding when the engine cuts, so I can officially rule out pump and regulator as possible causes. The M&W ignition is CDI, so no dwell times involved. However, the ignition signal does pass through a Bosch ignitor first, and I could see that possibly overheating and shutting down. What I don't understand is if that happens, I should lose my tach (being driven from the M&W CDI box), which I don't.

Next test is I'm going to see if I can rig up a timing light under the hood where I can see it while driving and then take it out (probably at night so I can see it) and then I'll know if the ignition is cutting out or not. Hopefully by then I'll have the VMWare/eManage issue resolved so I can get a datalog from eManage at the same time.
gstrudler is offline  
Old 03-26-2018, 10:41 PM
  #8  
Honda-Tech Member
Thread Starter
 
gstrudler's Avatar
 
Join Date: Oct 2007
Location: Oregon City, OR, USA
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

Well just talked with M&W and as somewhat expected, the tach output is driven by the sum of all the inputs. Given the fact that the tach keeps functioning normally when the motor dies, that makes it highly unlikely anything is wrong with the ignition (from what I've seen their boxes will also completely shut off if there's a failure in the output stage, but I'm waiting to hear back on that); but I'll try to check to be sure.

If it's not the ignition, about the only thing left is the injectors, which I would assume the problem would be with the injector drivers inside the eManage if that's the case...
gstrudler is offline  
Old 03-27-2018, 04:30 PM
  #9  
Honda-Tech Member
 
motoxxxman's Avatar
 
Join Date: Mar 2005
Location: CT, US
Posts: 2,365
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

the fact that the emanage datalog is cutting out makes me think that issue is related to this issue. I'd be willing to bet if you can fix the connection problem that it'll fix the engine cutting out problem too. Possibly bad ground or power supply? possibly dropping tach signal at the emanage?
motoxxxman is offline  
Old 07-31-2018, 10:57 PM
  #10  
Honda-Tech Member
Thread Starter
 
gstrudler's Avatar
 
Join Date: Oct 2007
Location: Oregon City, OR, USA
Posts: 1,746
Likes: 0
Received 0 Likes on 0 Posts
Default Re: eManage Ultimate gurus? Fuel cut?

Just to update in case someone else runs into this weird issue. I can't say it's conclusive for sure since I don't drive the car much anymore, but it did appear to be a problem with the EMU. Not only would it not stall when datalogging, but I noticed sometimes as soon as I plugged my computer into the EMU the idle speed would change, which seemed really strange. I forced a firmware update to it and also reset the stock ECU for good measure and the problem went away. Hoping it doesn't come back...
gstrudler is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
teg racer 877
Acura Integra
28
10-11-2018 04:41 AM
Imissvtec
All Motor / Naturally Aspirated
1
06-07-2007 10:28 AM
lv6l
Forced Induction
20
06-05-2006 09:33 PM
jwcardy
Forced Induction
2
04-04-2004 02:53 PM
DXDOHCVTEC
Honda CRX / EF Civic (1988 - 1991)
7
08-30-2003 03:56 AM


Thread Tools
Search this Thread
Quick Reply: eManage Ultimate gurus? Fuel cut?


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: