Go Back   Honda-Tech > Honda and Acura Model-Specific Technical Forums > Honda Element & CR-V
Sign in using an external account
Register Forgot Password?
Search


Welcome to Honda-Tech!
Welcome to Honda-Tech.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Honda-Tech community today!


Reply
 
 
 
submit to reddit
 
Thread Tools Search this Thread
Old 03-25-2011, 12:04 PM   #1
isitafox
Trial User
Garage is empty, add now
 
isitafox's Avatar
 
Join Date: Jan 2005
Location: Chinley, High Peak, UK
Posts: 3
iTrader Rating: (0)
Default 02 CRV K20 ecu showing p0341, HELP!!

I'm having trouble with my K20'd CRV and no one seems to be able to solve it for me!
When you start the engine cold it struggles to run for about 3 secs then dies and you can't restart again for about 10-15mins, if you hold the revs to above 1500rpm as soon as you start it though for around 3 secs the engine will pick up and run normally. Once it has warmed up the problem goes and it will start 1st time every time which is making diagnosis really difficult. I've had the ecu scanned and it was showing p0341 which according to the Snap On diagnosis units was the bank 1 CMP sensor playing up, I replaced this but it has made no difference whatsoever. The next thing suggested was maybe the temp sender unit wasn't working properly as the temp gauge permanantly shows above what it should so we assumed when the engine was cold the auto choke wasn't coming on, which explained why the engine would run perfectly well when warmed up but I replaced that as well and it's still the same.
Can someone on here PLEASE help me, I'm desperate to get this sorted as it's been the same since about October and we just want to get it fixed so we can sell the car!

Last edited by isitafox; 03-25-2011 at 12:04 PM. Reason: Added additional info in title
isitafox is offline   Reply With Quote
Old 03-25-2011, 12:39 PM   #2
grey_box008
Honda-Tech Member
Garage is empty, add now
 
Join Date: Jan 2011
Posts: 38
iTrader Rating: (0)
Default Re: 02 CRV K20 ecu showing p0341, HELP!!

What ECU do you have in it? A stock ECU will not run a k20 well, unless that is what it came with from the factory(not sure how it is across the pond, but all CRVs here have k24s).

If this is the case, then the CMP may not be reading right as it is looking for the value from a K24.
__________________
2008 Galaxy Grey Metalic Element SC- GT3076R powered
http://www.elementownersclub.com/for...ad.php?t=57738
grey_box008 is offline   Reply With Quote
Old 03-25-2011, 12:53 PM   #3
isitafox
Trial User
Garage is empty, add now
 
isitafox's Avatar
 
Join Date: Jan 2005
Location: Chinley, High Peak, UK
Posts: 3
iTrader Rating: (0)
Default Re: 02 CRV K20 ecu showing p0341, HELP!!

No all CRV's over here run either K20's or whatever the new diesel engine is. Petrol prices are a bit too costly to run a 2.4, currently at least 1.31 a litre so about $2 and will only ever go up!!
isitafox is offline   Reply With Quote
Old 03-25-2011, 01:46 PM   #4
grey_box008
Honda-Tech Member
Garage is empty, add now
 
Join Date: Jan 2011
Posts: 38
iTrader Rating: (0)
Default Re: 02 CRV K20 ecu showing p0341, HELP!!

I thought that was the case, but couldn't say for sure.

Gas prices here are skyrocketing as well.. I paid $3.79/gal for 93oct last night.

Ok, on to the next question then. What motor came from the factory in the car(i.e. k20a3, k20a2, etc.), and what model are you running now? If you switched to a true vtec type block from the more economy minded form, the sensors are different I believe. Check the engine code, and compare to the original.
__________________
2008 Galaxy Grey Metalic Element SC- GT3076R powered
http://www.elementownersclub.com/for...ad.php?t=57738
grey_box008 is offline   Reply With Quote
 
 
 
submit to reddit
Reply

Tags
02, 03, 10, 15, 2001, 24, cmp, code, cr, crv, dies, ecu, honda, k20, p0341, restarts

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT -8. The time now is 09:52 PM.



2008 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details