B16A speedometer/speed sensor problem - Honda-Tech

Go Back   > >
Log In 


B16A speedometer/speed sensor problem

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-03-2008, 12:22 PM   #1
Honda-Tech Member
Thread Starter
 
Richyrich1988's Avatar
 
Join Date: Oct 2008
Location: Pascagoula, MS, USA
Posts: 31
Default B16A speedometer/speed sensor problem

ok here it is. i have a 88 honda CRX with a JDM B16a with jackson racing supercharger and many other parts but my problem lies in my speedometer. the speedometer worked for about the first year i had it. i've had it for almost 3 years now. my RPM's work fine just speedometer. i have changed the speed sensor itself but that did not fix the problem so i think its in the wiring. also my gauge cluster is not the factory honda crx gauges. im not sure which they came from but redline is at 8 and top speed says 140. im pretty sure they go with the motor. my motor came out of a 91 crx i presume since its a true B16A not A1 or A2. from what i've heard they put B16A's in the 91 crx's. so when they did the motor swap they converted it from the classic speed cable to electric reading i guess cause the old cable is not in use. but i have spent hours on this and its beyond me any help will be greatly appreciated!!! thanks!!!! O and one more thing i forgot to mention. i have an aftermarket Zdyne ECU and my check engine light is on probably because the Speedo dosen't work but for some reason my VTEC still works despite the Speedo not working lol so i dont know why the speedo dont work but at least i have VTEC. anyway i would like to try and get the speedo back up and running. any help will be greatly appreciated!!!!

The Motor:






And here is the Speed Sensor


Modified by Richyrich1988 at 3:00 PM 10/3/2008


Modified by Richyrich1988 at 3:19 PM 10/3/2008
Richyrich1988 is offline   Reply With Quote
Old 10-03-2008, 01:10 PM   #2
Honda-Tech Member
Thread Starter
 
Richyrich1988's Avatar
 
Join Date: Oct 2008
Location: Pascagoula, MS, USA
Posts: 31
Default Re: B16A speedometer/speed sensor problem (Richyrich1988)

it turns out the cluster that's in my car is an Integra GSR cluster. just to let yall know what im dealing with.


here are some pics of the car and cluster




Modified by Richyrich1988 at 2:37 PM 10/3/2008

















Seats


Here is my Gauge Cluster




Modified by Richyrich1988 at 2:53 PM 10/3/2008


Modified by Richyrich1988 at 2:59 PM 10/3/2008


Modified by Richyrich1988 at 3:02 PM 10/3/2008
Richyrich1988 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LOTS of EF, da, and some cb parts. oldskool! For Sale 7 04-12-2013 03:03 PM
FS:Honda ACCESS Parts 4 Wagon Sedan HB CRX Salem,OR oldskool! For Sale 7 04-12-2013 06:40 AM
STOLEN.. Des Moines DC206R Northwest 47 10-12-2010 05:16 PM
Fs: Work Emotion CR-Kai White 15X7 +44 4x100 EG-SEX Southern California (Sales) 53 04-13-2010 05:48 PM
GSR throttle body on AEBS intake.. janky throttle cable?? jus_spooln_wicha Honda Civic / Del Sol (1992 - 2000) 13 01-02-2008 09:12 AM


Tags
b16, b16a, changed, crx, honda, location, problem, problems, sensor, spedometer, speed, speedmeter, speedometer, transmission, vtec, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:12 AM.



Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.