Go Back   Honda-Tech > Honda and Acura Model-Specific Technical Forums > Honda Civic/Del Sol (1992 - 2000)
Sign in using an external account
Register Forgot Password?
Search


Welcome to Honda-Tech!
Welcome to Honda-Tech.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Honda-Tech community today!


Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
Old 10-25-2011, 06:02 PM   #1
Honda-Tech Member
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Turn Signals not working

My turn signals work one min. then don't work the next. They started messing up after I hit the hazard lights button. It chooses when to work.
Ek Steve is offline   Reply With Quote
Old 10-25-2011, 06:32 PM   #2
Honda-Tech Member
 
sde780's Avatar
 
Join Date: Dec 2007
Location: Morgantown, WV, USA
Posts: 4,579
iTrader Rating: (0)
Send a message via AIM to sde780
Default Re: Turn Signals not working

Check fuses, make sure one of the bulbs isn't burnt/starting to fail
__________________
2012 Tacoma DCLB
https://www.youtube.com/user/shengdama?feature=mhee
sde780 is offline   Reply With Quote
Old 10-25-2011, 07:10 PM   #3
Honda-Tech Member
 
Slacker93eg's Avatar
 
Join Date: Apr 2011
Location: Chicago
Posts: 804
iTrader Rating: (0)
IR_Slacker
Default Re: Turn Signals not working

Mines doing the same thing, all the sockets wiring is screwed up.
__________________
93 Honda Civic Hatchback
LSVtec Turbo Build
Check out RC Autoworks
Slacker93eg is offline   Reply With Quote
Old 10-25-2011, 07:22 PM   #4
Honda-Tech Member
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Re: Turn Signals not working

Quote:
Originally Posted by Slacker93eg View Post
Mines doing the same thing, all the sockets wiring is screwed up.
Do the turn signal lights blink on the dash when the blinkers aren't working? Mine doesn't show up at all and it makes a noise like they are on, but they aren't.
Ek Steve is offline   Reply With Quote
Old 10-25-2011, 08:01 PM   #5
Honda-Tech Member
 
Join Date: Oct 2011
Location: Orange,So Cal
Posts: 69
iTrader Rating: (0)
Default Re: Turn Signals not working

The same thing happened to me when i replace my radio unit , i forgot to plug back the hazard lights button, if all your fuses and wires are correct take a look at it. or maybe is just a fuse .
vinem1 is offline   Reply With Quote
Old 10-25-2011, 08:24 PM   #6
Honda-Tech Member
 
EJ2B16's Avatar
 
Join Date: Oct 2011
Location: cali
Posts: 39
iTrader Rating: (0)
Default Re: Turn Signals not working

same problem with my civic!!!!
i have to turn my blinkers 10sec before i want to turn and all of a sudden they work. dont know what it is. any help?. its not the fuses its not the bulbs....

http://thehid-spot.webs.com/
http://thehid-spot.webs.com/
http://thehid-spot.webs.com/

Last edited by EJ2B16; 03-05-2012 at 12:15 AM.
EJ2B16 is offline   Reply With Quote
Old 10-25-2011, 09:44 PM   #7
Honda-Tech Member
 
sde780's Avatar
 
Join Date: Dec 2007
Location: Morgantown, WV, USA
Posts: 4,579
iTrader Rating: (0)
Send a message via AIM to sde780
Default Re: Turn Signals not working

Quote:
Originally Posted by Ek Steve View Post
Do the turn signal lights blink on the dash when the blinkers aren't working? Mine doesn't show up at all and it makes a noise like they are on, but they aren't.
So the relay clicks but there's no light? Did you check the bulbs?
__________________
2012 Tacoma DCLB
https://www.youtube.com/user/shengdama?feature=mhee
sde780 is offline   Reply With Quote
Old 10-25-2011, 09:52 PM   #8
Honda-Tech Member
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Re: Turn Signals not working

Quote:
Originally Posted by sde780 View Post
So the relay clicks but there's no light? Did you check the bulbs?
yes and when it is working the turn signals show up on my dash so it cant be the bulbs
Ek Steve is offline   Reply With Quote
Old 10-25-2011, 10:25 PM   #9
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,472
iTrader Rating: (0)
Default Re: Turn Signals not working

Pry the hazard lights switch out of the dash and check whether the connector is not fully seated on the switch.
__________________
.
Don't guess, troubleshoot

Technical links:
FAQs sticky...CEL Codes...Spark diagnosis...
Testing Fuses...Fuse 15 TSB...Cleaning the IACV or FITV

92-00 Civic Forum Rules
RonJ@HT is online now   Reply With Quote
Old 10-26-2011, 04:48 PM   #10
Honda-Tech Member
 
Ek Steve's Avatar
 
Join Date: Oct 2011
Location: Southlands
Posts: 11
iTrader Rating: (0)
Sick ITR EK9
Default Re: Turn Signals not working

it was the hazards, its fixed now thanks guys. oh and does anyone know why my blinker switch doesn't click off when i turn( i have a momo steering wheel if that helps). Thanks!
Ek Steve is offline   Reply With Quote
Old 10-28-2011, 08:02 PM   #11
Honda-Tech Member
 
Join Date: Oct 2011
Location: Orange,So Cal
Posts: 69
iTrader Rating: (0)
Default Re: Turn Signals not working

You probably need to replace the blinker switch or try to clean it and check the cables.
vinem1 is offline   Reply With Quote
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals don't work! :( triagnecriadrmy Honda Accord (1990 - 2002) 0 02-02-2011 08:29 PM
turning signals dont work? elbeanerhatch Acura Integra 5 11-04-2008 04:00 PM
Turn signals and hazards do not work kwalzy Honda Accord (1990 - 2002) 5 03-19-2008 01:12 PM
is there a relay for my turn signals? turboah Honda Accord (1990 - 2002) 1 01-02-2007 01:35 PM
Turn signal help! SYTFU Tommy. Acura Integra 8 08-23-2004 08:32 AM


Tags
93, blinkers, civic, del, dont, ep3, honda, kswap, signal, signals, sol, stopped, turn, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 01:46 PM.



2014 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details