Go Back   Honda-Tech > Honda and Acura Model-Specific Technical Forums > Honda Civic/Del Sol (1992 - 2000)
Sign in using an external account
Register Forgot Password?
Search


Welcome to Honda-Tech!
Welcome to Honda-Tech.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Honda-Tech community today!


Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
Old 03-31-2009, 08:47 PM   #1
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default injectors/fuel pump run constantly.. Help me dammnit

I am working on a 96' Honda Civic for my friend. With the key in the on position, main relay doesnt kick off nor the fuel pump or injectors. injectors spray engine full of fuel. main relay and computer are good, and main wiring harness has been changed. with injectors unplugged fuel pump still wont turn off. it is a d16y7 by the way.
superslinky is offline   Reply With Quote
Old 03-31-2009, 09:02 PM   #2
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

The ECU is bad (providing constant ground to A16 ECU terminal that activates the fuel pump) or the wire between the main relay and the ECU A16 terminal is damaged and grounding out.
RonJ@HT is online now   Reply With Quote
Old 04-02-2009, 07:00 PM   #3
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

Thanks for your comment. I just replaced engine harness that runs to ECU and main harness has already been changed both harnesses are good because they came off a running car. I also changed crank sensor today. Now I really don't know what to do and its aggravating me.
superslinky is offline   Reply With Quote
Old 04-02-2009, 07:43 PM   #4
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

1) Turn the key OFF and disconnect the connector to the main relay.

2) Turn the key to ON(II) and then measure the voltage at terminal 2 of the connector to body ground (see diagram below). Do you measure any voltage?



Click the image to open in full size.
RonJ@HT is online now   Reply With Quote
Old 04-02-2009, 08:39 PM   #5
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

ok, i just got back from checkin the plug and #2 (blue and white) terminal had nothing, with key on or off, in all three positions. there was only 2 other wires that had voltage. on your diagram the ones that had voltage where, #5 and #7.
superslinky is offline   Reply With Quote
Old 04-02-2009, 09:09 PM   #6
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

When the key is turned to ON(III), does the starter crank the engine?

Does the fuel pump run continuously only when the key is turned to ON(II)?
RonJ@HT is online now   Reply With Quote
Old 04-02-2009, 09:22 PM   #7
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

with the key in the on II position the fuel pump and injectors run constantly. one more turn from the on II position which is III the engine cranks, and fuel pump and injectors still run while cranking. should the blue and white wire have voltage? can i test this by running a wire from the A16 ecu plug to the #2 blue and white wire located on the main relay plug? or is that a dumbass question resulting in a fried ecu? so many questions, but you are helping tremendously. i mean i have wired up resistor boxes, vtec and several other things, but this is a problem i have never delt with before.
superslinky is offline   Reply With Quote
Old 04-02-2009, 09:41 PM   #8
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

Quote:
Originally Posted by superslinky View Post
with the key in the on II position the fuel pump and injectors run constantly. one more turn from the on II position which is III the engine cranks, and fuel pump and injectors still run while cranking. should the blue and white wire have voltage? can i test this by running a wire from the A16 ecu plug to the #2 blue and white wire located on the main relay plug? or is that a dumbass question resulting in a fried ecu? so many questions, but you are helping tremendously. i mean i have wired up resistor boxes, vtec and several other things, but this is a problem i have never delt with before.
The blue/white wire should only register battery voltage when the key is turned to ON(III), so the test you did yielded the proper outcome. That ruled out the possibility that unexpected power from the blue/white was causing the fuel pump to run continuously. In addition, detection of voltage at position 5 and 7, but not others, was also proper.

At this point, I think there could be three different causes:

1) A bad main relay (you can test it)
2) A bad ECU inappropriately providing constant ground at terminal A16.
3) The ECU is receiving an incorrect signal from the crank angle sensor circuit in the distributor indicating that the engine is turning.


When you turn the key to ON(II), does the CEL remain ON or turn OFF after 2 seconds? If it remains ON, can you pull any codes when you jump the service connector?

Last edited by RonJ@HT; 04-02-2009 at 10:00 PM.
RonJ@HT is online now   Reply With Quote
Old 04-02-2009, 10:10 PM   #9
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

1) A bad main relay (you can test it)
2) A bad ECU inappropriately providing constant ground at terminal A16.
3) The ECU is receiving an incorrect signal from the crank angle sensor circuit in the distributor indicating that the engine is turning.

#1 and #2 is ruled out. But #3 is a possiblity. Yes the CEL stays on. It will not let me run a diagnostics on it, it just shows up error. With the key in the on (III) position (cranking) should the blue and white wire have power? Is there any way I can check the A16 terminal, and if there is can you send me a diagram of the ECU pigtails? I had a diagram but I lost it and I can't remember what site to go to and recieve it..
superslinky is offline   Reply With Quote
Old 04-02-2009, 10:22 PM   #10
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

Yes, the blue/white wire should have power when the key is turned to ON(III).

Are you able to start and run the engine?
RonJ@HT is online now   Reply With Quote
Old 04-02-2009, 10:41 PM   #11
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

No, the engine will not start and run. I think due to someone else working on it and fouling the plugs cause engine is full of fuel including mixed in the oil. i just checked the blue and white wire while cranking it and it did have power.
superslinky is offline   Reply With Quote
Old 04-02-2009, 10:56 PM   #12
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

Yeah, the engine sounds flooded. You should drain the oil and refill with new oil to see whether the engine will start. This will help with the troubleshooting charts below:

Click the image to open in full size.

Click the image to open in full size.

Click the image to open in full size.
RonJ@HT is online now   Reply With Quote
Old 04-02-2009, 11:19 PM   #13
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

ok thanks. i will study this and get back with you.
superslinky is offline   Reply With Quote
Old 04-10-2009, 07:16 PM   #14
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

i fixed it to where i can read codes now, but there are no codes showing up. wtf. idk.
superslinky is offline   Reply With Quote
Old 04-11-2009, 01:36 AM   #15
Honda-Tech Member
 
crxboy909's Avatar
 
Join Date: Jan 2008
Location: San Bernardino, CA, USA
Posts: 258
iTrader Rating: (0)
crxboy909
Send a message via AIM to crxboy909
Default Re: injectors/fuel pump run constantly.. Help me dammnit

there is probably a wire running direct from the battery to the car... cause thats how mines was when i first bought it
__________________
91 Prelude Si - R.I.P.
88 CRX Dx - Police Impounded
93 Civic Ex - Stolen
crxboy909 is offline   Reply With Quote
Old 04-14-2009, 08:36 PM   #16
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

are u talking about from the positive side, grouding out on the car?
superslinky is offline   Reply With Quote
Old 04-14-2009, 09:19 PM   #17
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

What was the causing the inability to pull codes?

Does the CEL remain ON steady with and without the service connector jumped?

Do the fuel pump and injectors still run continuously?
RonJ@HT is online now   Reply With Quote
Old 04-15-2009, 09:39 PM   #18
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

im not exactly sure the reason of the inability to pull codes, cause i done several different things that day, including changing the distributor. yes the cel is still on bright and yellow as it can be. no codes are yet to be pulled. i did try unplugging the fuel pump and then plugging the injectors up, and the injectors still run until all fuel pressure is exempt from the fuel lines. i think im goin to just scrap the piece of ****!
superslinky is offline   Reply With Quote
Old 04-15-2009, 09:45 PM   #19
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

At this point, my guess is that your ECU is bad. Why don't you believe this is a possibility?
RonJ@HT is online now   Reply With Quote
Old 04-15-2009, 09:55 PM   #20
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

i put the computer out of my running car into this car with the problems, and still the same thing. i kno, im thinkin the same thing, wtf. i did talk to a very well educated mechanic i have known for a while today. he said it makes no sense also, but he did say he would contact his friend at honda for further info. i will keep you posted on this issue.
superslinky is offline   Reply With Quote
Old 04-16-2009, 05:34 AM   #21
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

Have you done any of the electrical troubleshooting from the diagrams in post #12? For example, unplugging sensors to test whether the CEL turns OFF:

Click the image to open in full size.
RonJ@HT is online now   Reply With Quote
Old 04-22-2009, 09:11 PM   #22
Junior Member
 
Join Date: Mar 2009
Posts: 17
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

yes i tried that, cel still stays on. the owner of the car came and picked it up and is taking it to somone else, honda i think. although he is supposed to call me and let me know what the problem was, if it can be fixed. i think the s.o.b is haunted. as soon as he lets me know what it was or is, i will let you know. thanks for all your help.
superslinky is offline   Reply With Quote
Old 04-22-2009, 10:08 PM   #23
Raising the bar
 
RonJ@HT's Avatar
 
Join Date: Feb 2008
Location: Houston, Texas
Posts: 35,383
iTrader Rating: (0)
Default Re: injectors/fuel pump run constantly.. Help me dammnit

Good luck. I'm interested to know how this turns out.
RonJ@HT is online now   Reply With Quote
 
 
 
submit to reddit
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
ecu not grounding main relay, jumped ground and worked fasteddief23 Honda Accord (1990 - 2002) 26 07-06-2011 02:31 PM
HELP my Injectors don't seem like their working tundra2000 Honda Civic/Del Sol (1992 - 2000) 2 06-09-2010 07:33 PM
injectors dumping KYSI Honda Civic/Del Sol (1992 - 2000) 19 03-24-2010 12:18 PM
Fuel pump priming PROBLEM >? ECU or relay or fize HELP PLEASE> krysted9354 Honda Civic/Del Sol (1992 - 2000) 20 04-08-2009 04:32 PM
main relay! mikester1222 Honda Civic/Del Sol (1992 - 2000) 2 05-19-2008 11:10 PM


Tags
96, car, cel, civic, constantly, continuously, fuel, honda, injector, key, keyed, pressure, pump, run, runs, stays

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -8. The time now is 06:13 AM.



2014 Copyright, InternetBrands Inc.
Powered by vBulletin® Version 3.8.7 AC1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.
Emails & Contact Details