corrosion inside my distributor - Honda-Tech

Go Back   >
Log In 


corrosion inside my distributor

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-09-2007, 05:20 PM   #1
Honda-Tech Member
Thread Starter
 
Ruben19's Avatar
 
Join Date: Dec 2005
Location: Panama, Panama
Posts: 3,548
Default corrosion inside my distributor

i had this problem since i bought the car. Corrosion build up on the 4 terminal inside the cap. this make my car misfire and lose power. Couple of years later i bought a msd kit, that include the box,coil and cap. same problem. i bought different caps and rotor but still the same ****.
im thinking about getting rid of the msd system and buy a new distributor. I have to clean the corrosion every week so the car can run in better conditions.
let me know what you think
Is a 2000 si

Ruben19 is offline   Reply With Quote
Old 09-10-2007, 10:38 AM   #2
Honda-Tech Member
Thread Starter
 
Ruben19's Avatar
 
Join Date: Dec 2005
Location: Panama, Panama
Posts: 3,548
Default

come on guys.
i know someone had this problem before.
Ruben19 is offline   Reply With Quote
Old 09-10-2007, 10:48 AM   #3
 
Kegan's Avatar
 
Join Date: Aug 2007
Location: Ft.McCoy, WI, US
Posts: 59
Default

Make sure you use the seal that comes with the cap. That could be a cause.
Kegan is offline   Reply With Quote
Old 09-10-2007, 10:48 AM   #4
Honda-Tech Member
 
EG2Driver's Avatar
 
Join Date: Sep 2005
Posts: 3,003
Default Re: (Ruben19)

mine used to misfire every so often because the seal to the distributor cap was too thin, even though it came from Honda. I used some dielectric grease on the seal and haven't had any problems with it. I stored the car outside last winter for 5 months and it started right up after that time.

Try that and then see if that works.
EG2Driver is offline   Reply With Quote
Old 09-10-2007, 10:53 AM   #5
Honda-Tech Member
 
carloselpavo's Avatar
 
Join Date: Aug 2007
Location: South From Seattle, WA, USA
Posts: 133
Default Re: corrosion inside my distributor (Ruben19)

What cap & rotor are you running now? the problem might be on the conbination
carloselpavo is offline   Reply With Quote
Old 09-10-2007, 12:03 PM   #6
Honda-Tech Member
Thread Starter
 
Ruben19's Avatar
 
Join Date: Dec 2005
Location: Panama, Panama
Posts: 3,548
Default

msd cap and rotor.
new seal and i always use dielectric gease.
im buying a new distributor.
Ruben19 is offline   Reply With Quote
Old 09-10-2007, 01:12 PM   #7
Honda-Tech Member
 
carloselpavo's Avatar
 
Join Date: Aug 2007
Location: South From Seattle, WA, USA
Posts: 133
Default Re: (Ruben19)

My car was doing the same until I use a msd cap with a rotor that wasn't copper. 4 months with that set up and no problems.
carloselpavo is offline   Reply With Quote
Old 09-10-2007, 10:34 PM   #8
Honda-Tech Member
Thread Starter
 
Ruben19's Avatar
 
Join Date: Dec 2005
Location: Panama, Panama
Posts: 3,548
Default

i used none copper rotor before.
same result
Ruben19 is offline   Reply With Quote
Old 09-11-2007, 06:50 AM   #9
Honda-Tech Member
 
carloselpavo's Avatar
 
Join Date: Aug 2007
Location: South From Seattle, WA, USA
Posts: 133
Default Re: (carloselpavo)

well you said you were using msd cap & rotor. MSD parts are copper. if so, keep the cap and change the rotor for a steel looking one.
carloselpavo is offline   Reply With Quote
Old 09-11-2007, 10:22 AM   #10
Honda-Tech Member
Thread Starter
 
Ruben19's Avatar
 
Join Date: Dec 2005
Location: Panama, Panama
Posts: 3,548
Default Re: (carloselpavo)

Quote:
Originally Posted by carloselpavo
well you said you were using msd cap & rotor. MSD parts are copper. if so, keep the cap and change the rotor for a steel looking one.
did that already but same ****.
Ruben19 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
White residue corrosion on Ignition coil lead ? Rob. Honda CRX / EF Civic (1988 - 1991) 1 06-10-2009 11:42 AM
Replacing battery cables... ERIC! Acura Integra 4 03-12-2008 11:09 AM
Spark problem? jdsmooth Honda Accord (1990 - 2002) 7 03-07-2008 04:59 PM
corrosion inside distributor cap bizmackus Acura Integra 1 02-25-2007 09:33 PM
alternator corrosion??? 98prelude98 Honda Prelude 1 06-02-2005 09:12 AM


Tags
98, build, cap, caps, civic, corroded, corrosion, corrossion, distributer, distributor, honda, hondatech, inside, msd, rust, terminals

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:08 PM.



Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.