bad engine coolant temp sensor? - Honda-Tech

Go Back   >
Log In 

bad engine coolant temp sensor?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-23-2009, 04:28 PM   #1
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2008
Posts: 13
Default bad engine coolant temp sensor?

so ive been having a rev limit of 4k rpm when i cold start my car. if i let it warm up and restart the car it stops. if i reset the cel while its warm it does not come back on until i cold start again. so i replaced the engine coolant temp sensor but it still does the same thing. any ideas?

thanks
davidfillups is offline   Reply With Quote
Old 02-23-2009, 05:19 PM   #2
DC5/EP3 MOD :)
 
Type-Spaz's Avatar
 
Join Date: Sep 2008
Location: WI
Posts: 2,659
Default Re: bad engine coolant temp sensor?

what is the actually engine code being thrown?
Type-Spaz is offline   Reply With Quote
Old 02-23-2009, 05:32 PM   #3
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2008
Posts: 13
Default Re: bad engine coolant temp sensor?

i dont know. i didnt run a diagnostic. i know i should have done that in the first place but i didnt and i wanted to see if anyone had any suggestions before i do.
davidfillups is offline   Reply With Quote
Old 02-23-2009, 05:42 PM   #4
DC5/EP3 MOD :)
 
Type-Spaz's Avatar
 
Join Date: Sep 2008
Location: WI
Posts: 2,659
Default Re: bad engine coolant temp sensor?

do you have k-pro ?
Type-Spaz is offline   Reply With Quote
Old 02-23-2009, 05:57 PM   #5
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2008
Posts: 13
Default Re: bad engine coolant temp sensor?

No
davidfillups is offline   Reply With Quote
Old 02-23-2009, 07:15 PM   #6
Honda-Tech Member
 
Join Date: Jan 2002
Posts: 5,501
Default Re: bad engine coolant temp sensor?

anytime you have a cel the first thing you should do is check it. it's free at some places. knowing the code will save you a lot of time and headache.
vladd is offline   Reply With Quote
Old 02-23-2009, 07:22 PM   #7
Surje.motorsports
 
nahonda04's Avatar
 
Join Date: Aug 2007
Location: mechanicsburg, pa, usa
Posts: 3,523
Default Re: bad engine coolant temp sensor?

Quote:
Originally Posted by vladd View Post
anytime you have a cel the first thing you should do is check it. it's free at some places. knowing the code will save you a lot of time and headache.
yeah def get it checked out to see what code its throwing...autozone or advanced auto is free like vladd said
nahonda04 is offline   Reply With Quote
Old 02-23-2009, 07:37 PM   #8
El Presidente
 
DaveSi677's Avatar
 
Join Date: Sep 2003
Location: Toronto, Canada but from Montreal
Posts: 8,035
Default Re: bad engine coolant temp sensor?

Hey Dave don't sweat it... you got to learn sooner or later how to do things right the first time... what I suggest is go get that code and comeback here and post it and will give you a hand at figuring it out!

Remember when it comes to check engine light always get the code it help to point you and us in the right direction!
DaveSi677 is offline   Reply With Quote
Old 02-23-2009, 08:12 PM   #9
DC5/EP3 MOD :)
 
Type-Spaz's Avatar
 
Join Date: Sep 2008
Location: WI
Posts: 2,659
Default Re: bad engine coolant temp sensor?

Quote:
Originally Posted by DaveSi677 View Post
Hey Dave don't sweat it... you got to learn sooner or later how to do things right the first time... what I suggest is go get that code and comeback here and post it and will give you a hand at figuring it out!

Remember when it comes to check engine light always get the code it help to point you and us in the right direction!
Very true and well said.
Type-Spaz is offline   Reply With Quote
Old 02-24-2009, 05:13 AM   #10
Honda-Tech Member
 
turboteg2nv's Avatar
 
Join Date: Jan 2004
Location: Cincinnati, OH
Posts: 2,788
Default Re: bad engine coolant temp sensor?

Are you sure it's not just the fast-idle for cold starts?

It sounds like your temp sensor is working fine to me.
turboteg2nv is offline   Reply With Quote
Old 02-24-2009, 09:36 AM   #11
DC5/EP3 MOD :)
 
Type-Spaz's Avatar
 
Join Date: Sep 2008
Location: WI
Posts: 2,659
Default Re: bad engine coolant temp sensor?

I thought it was IACV but someone cleared the codes......NOOB
Type-Spaz is offline   Reply With Quote
Old 02-25-2009, 12:53 PM   #12
Junior Member
 
stickyicky's Avatar
 
Join Date: Oct 2008
Location: Stanton, CA, USA
Posts: 79
Default Re: bad engine coolant temp sensor?

why are you even reving it to 4k when its cold???
stickyicky is offline   Reply With Quote
Old 02-25-2009, 03:22 PM   #13
Honda-Tech Member
 
hawaiiancb74's Avatar
 
Join Date: Feb 2006
Location: WPAFB, Ohio, United States
Posts: 1,006
Default Re: bad engine coolant temp sensor?

thats honestly not gona hurt it, as long as it has oil in it 4k is nuttin. live where its cold you realize it could take 30 mins for a car to start to get warmish
hawaiiancb74 is offline   Reply With Quote
Old 02-25-2009, 03:36 PM   #14
Junior Member
 
stickyicky's Avatar
 
Join Date: Oct 2008
Location: Stanton, CA, USA
Posts: 79
Default Re: bad engine coolant temp sensor?

Quote:
Originally Posted by hawaiiancb74 View Post
thats honestly not gona hurt it, as long as it has oil in it 4k is nuttin. live where its cold you realize it could take 30 mins for a car to start to get warmish
when you turn on a car that is cold, the ecu is running in open loop which means the AF mixture is running rich, which then could cause your catalytic to run dangerously hot and cause a fire.

TS is saying his revs are limited to 4k..which is limp mode. which means there is something wrong with the car and the ECU is trying to prevent a major problem.

i say you replace the ECT sensor.. and you'll be ok
stickyicky is offline   Reply With Quote
Old 02-25-2009, 03:46 PM   #15
Honda-Tech Member
 
hawaiiancb74's Avatar
 
Join Date: Feb 2006
Location: WPAFB, Ohio, United States
Posts: 1,006
Default Re: bad engine coolant temp sensor?

been doin it for 20 yrs never had a problem, been a honda mechanic for 6, but yeah the car is in limp mode, and more than likely it is the ect sensor, but getting the code would be a sure fire way to know the ecu is doing.
hawaiiancb74 is offline   Reply With Quote
Old 02-26-2009, 08:07 AM   #16
Junior Member
 
stickyicky's Avatar
 
Join Date: Oct 2008
Location: Stanton, CA, USA
Posts: 79
Default Re: bad engine coolant temp sensor?

Quote:
Originally Posted by hawaiiancb74 View Post
been doin it for 20 yrs never had a problem, been a honda mechanic for 6, but yeah the car is in limp mode, and more than likely it is the ect sensor, but getting the code would be a sure fire way to know the ecu is doing.
I doubt you have ran a car "hard" like this for 20 years and not had to replace the prematurely worn : catalytic converter, piston rings,o2 sensors.
Congrats on being a honda tech, but this problem just isnt relevant to Hondas...It goes for all cars...
stickyicky is offline   Reply With Quote
Old 02-26-2009, 09:23 AM   #17
Honda-Tech Member
 
hawaiiancb74's Avatar
 
Join Date: Feb 2006
Location: WPAFB, Ohio, United States
Posts: 1,006
Default Re: bad engine coolant temp sensor?

i know that, and i dont stick at 4 grand, i let the car typicaly go to 4 grand and then shift, ive never had to replace a cat, or an 02 sensor on my cars, piston rings yes, but that was a racing motor and didnt see cold weather. the only vehicle ive owned that wasnt a honda was my ford diesel, 4 grand wasnt exaclty gona happen on that truck.. lol but i do understand what your sayin
hawaiiancb74 is offline   Reply With Quote
Old 02-26-2009, 09:32 AM   #18
Junior Member
 
stickyicky's Avatar
 
Join Date: Oct 2008
Location: Stanton, CA, USA
Posts: 79
Default Re: bad engine coolant temp sensor?

what i have been saying is that if you run a car hard without letting it properly warm up there will be repercussions. You stated there wouldnt be.
stickyicky is offline   Reply With Quote
Old 02-26-2009, 10:23 AM   #19
Member
 
GoLowDrew's Avatar
 
Join Date: Dec 1999
Location: East Palo Alto, CA
Posts: 88,564
Default Re: bad engine coolant temp sensor?

Is your car auto trans?

Have you try the same thing with the AC on at high?
GoLowDrew is offline   Reply With Quote
Old 02-26-2009, 01:19 PM   #20
Honda-Tech Member
 
hawaiiancb74's Avatar
 
Join Date: Feb 2006
Location: WPAFB, Ohio, United States
Posts: 1,006
Default Re: bad engine coolant temp sensor?

no i ment you can go to 4 grand with out hurting it, i wouldnt sugest doing it all the time or staying at 4 gand or above while cold.
hawaiiancb74 is offline   Reply With Quote
Old 03-14-2009, 10:32 AM   #21
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2008
Posts: 13
Default Re: bad engine coolant temp sensor?

hey guys sorry its been so long since i posted. i got the code read and its p1259 which is vtec failure. so i reset the CEL to see when the light came back on and it come on below 4k rpm but only on cold start if i let it warm up and reset the CEL it doesn't come on at all.
davidfillups is offline   Reply With Quote
Old 03-14-2009, 01:18 PM   #22
Honda-Tech Member
 
hawaiiancb74's Avatar
 
Join Date: Feb 2006
Location: WPAFB, Ohio, United States
Posts: 1,006
Default Re: bad engine coolant temp sensor?

check your oil
hawaiiancb74 is offline   Reply With Quote
Old 03-14-2009, 01:20 PM   #23
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2008
Posts: 13
Default Re: bad engine coolant temp sensor?

the oil level is fine. im going to change it in about an hour. ill post the results afterward
davidfillups is offline   Reply With Quote
Old 03-15-2009, 12:33 PM   #24
Honda-Tech Member
Thread Starter
 
Join Date: Aug 2008
Posts: 13
Default Re: bad engine coolant temp sensor?

i changed the oil. its still doing the same thing.
davidfillups is offline   Reply With Quote
Old 03-17-2009, 10:29 AM   #25
Honda-Tech Member
 
hawaiiancb74's Avatar
 
Join Date: Feb 2006
Location: WPAFB, Ohio, United States
Posts: 1,006
Default Re: bad engine coolant temp sensor?

bad vtec solenoid?
hawaiiancb74 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
coolant temperature sensor crxr82 Acura Integra 1 12-29-2008 09:27 AM
HELP CEL 6 coolant temp sensor. ChinQuee Honda Civic / Del Sol (1992 - 2000) 0 04-02-2008 09:43 AM
bad coolant temp sensor slammedz6ef Honda CRX / EF Civic (1988 - 1991) 10 02-13-2008 06:15 PM
car not warming up in cold weathers, bad for engine? yaoming315 Honda Civic / Del Sol (1992 - 2000) 9 02-04-2007 09:09 PM
Question about temp sensor on thermostat housing tgreaves Tech / Misc 3 05-27-2005 03:47 PM


Tags
2006, bad, change, civic, coolant, cost, ect, engine, honda, locations, odyssey, sensor, signs, temp, tran

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:42 PM.



Honda and the Honda marquee are registered trademarks of the American Honda Motor Company, Inc. Neither American Honda Motor Company nor its subsidiaries or affiliates shall bear any responsibility for Honda-Tech.com content, comments, or advertising. Honda-Tech.com is not affiliated with American Honda Motor Company in any way. American Honda Motor Company does not sponsor, support, or endorse Honda-Tech.com in any way. Copyright/trademark/sales mark infringements are not intended or implied.